Issues with MACOs

I am trying to port my project to MAC but sadly I think I am going to have to give up and cancel the contract with the client. I have to run the latest MacoS which means I have to use visual studio 2019. If I use the pipeline I get OS X/ffprobe not found on the mac then on windows with the project type set to MOC Os i get System.IO.InvalidDataException: ‘Could not determine container type!’ I have tried changing the sample rate and quality but no success.

I appreciate Monogame is developed by a very talented bunch of guys who spend alot of there spare time doing this. I do feel though at the moment the mac should be dropped as a platform until it supports the latest MacOs and visual Studio which is such a shame as I love the project and have been using it and talking to the community for about 7 years

if Monogame’s Mac version does not work, you might try and build with FNA instead?

Thanks for the tip but another part of the contract is to create an android version which FNA does not support. I am going to carry on fighting and see if I can pull this over the line

Catalina removed support for ALL 32 bit apps.

Make sure everything is 64 bit.

Hello, can someone please help me with this.

I installed Monogame, Mono and VS 2017 on MAC and all the templates show up but every time I try to create a new Project with the Monogame Templates I get the same error:

The project could not be created
Exception has been thrown by the target of an invocation.

I reinstalled everything several times but I still can’t create a project, maybe someone knows a workaround
thanks in advanced

I work on macOS Catalina
Monogame 3.7.1
Visual Studio 2017
MonoFramework 5.18.0