Lidgren.Network - talk talk?

Hi all

Here in the UK I’m using TalkTalk as my ISP. I’ve been playing around with the Lidgren Network library and have a client / server running on my local machine with no problems chatting to each other. I use a dynamic DNS to store our IP address and to access the IP using a name -

I’ve opened the TCP & UDP ports on the router for the port number I’m using, and my windows firewall and I’m having no luck in the client application going out to the ISP IP address of the router and connecting to the server - I’ve even asked my brother (not on my network) to try connecting to my server using the client, but having no luck (yes, he’s also opened his ports).

I’ve even stopped windows firewall and all my anti virus/internet security software, but still having issues.

Does anyone have any idea what the problem is - and if you’re on the talk talk network using super fibre router - and have this working, how?

Would love to know how to get this working as it’s baffled me - and yes I know about port forwarding etc and have that pointing to the PC running the server… I’ve even tried the basic “ping” to the IP address of my router (not the internal local one -


Hi :slight_smile:
Where is your server situated ?
Do you have a diagram of your network ?
You can ping your router, but what is the result when pinging the server ? With the IP or the FQDN ?

Hi @Alkher

The server app is running on my local PC. in our house we have the Talk Talk Router (HG633) and then attached to that is 3 PCs mine being one of them. the server application is running on that, the client application I’ve ran on the same PC using “localhost” / and I’ve also ran the client application on another internal PC using the internal IP address of the server ( and all this works fine, the client and the server chat and my “test game” works.

So I’ve now opened the port on the router and forwarded it to my PC, ran the server application on my PC - Now with the client application I’ve tried 3 things.

  1. Ran client on SAME PC as server, but instead of using localhost/127… I’ve used the IP address the router has for the TT network - and also what my Dynamic DNS has for the router using this and also using my dynamic DNS name - “” the client and server are simply not talking.

  2. Ran the client on another PC on the same local network, again using the IP and dynamic name, same result as #1

  3. Gave my brother the client application opened the ports on his router and again same result - because 1 & 2 are not working, I think the problem is more local and to do with the router not being setup properly

I’ll do some more testing (ping/tracert) when I get home tonight after work (about 9 hrs from now) Maybe I did something wrong on the router - but setting up port forwarding is simple - The last time I did anything like this was a couple of years ago when I was on Virgin Media network and didn’t have any issues then.

I posted the above late last night (just as I went to bed) so I’ll check some talk talk forums etc today to see if I missed anything.

I’m correct in thinking that Lidgren used UDP right and not TCP. so that is the only port type I need to open (though I did both).

Just tried pinging the IP address from my WORK PC and I get a request time out - but maybe that could be my works network.

ping with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Do you have some logs on the server which may tell it has rejected connections ? Or on the TT router or in the Windows’ firewall ?
Are the port of the client and server different ?
Did you try to access your server without using DynDNS ? Iie. with the IP you have at home.

Maybe an option in Lidgren you missed ?

The Port number in the client and server application are the same - it works when both are run on the same PC.

As well as using the name in DynDNS I also tried the IP address directly - same result

Not checked any logs - not sure where the windows firewall logs are that shows rejected connection - not really messed around with it that much in the past, I’ll have another play around with that and the router tonight to see what else it might be.

Just an update, been reading up on the talktalk port forwarding and found something called port triggering - not sure what this is of exactly what the difference is, so I’ll have a play around with this tonight.

@Harag It is very common for ISPs to give a single public Internet Protocol (IP) address to their customers which act as the gateway. This policy is practical to slowdown the global IPv4 address exhaustion. Since all incoming and out coming traffic to and from the home network need to use this gateway, home routers use NAT (Network Address Translation) to map between local and public addressing information and vice versa. You will want to configure your home network’s router to forward incoming packets with a specific port from the Internet to a specific local IP address and port. You will also need to decide what transport protocol (TCP or UDP) is a best for your application as most routers want this information as well when port forwarding.

Hi all,

I think I’ve found the problem - the Talk Talk ISP router doesn’t do “NAT Loopback” so that is why I can’t seem to connect to my own server via the WAN IP address. Not sure why my brother couldn’t connect though - maybe he didn’t open the port properly at his end, we did another test where I had port 81 pointing to my IIS server, and he used his browser to go to:


and he saw the web page ok, so that is good news - I’ll have to teach how to open ports on his machine, maybe he did something wrong - brothers… Pah.

So now the next question - can anyone recommend a good router that does NAT LOOPBACK? to I can replace the talk talk router.?