MGCB.exe can't load freetype6.dll but mgcb-editor-wpf.exe can

I was working on a game on my laptop which I now copied to my desktop (on which I installed Monogame 3.7.1). I can run the build from my laptop on my desktop, but when building it on my desktop (from Visual Studio 2019) it gives the error: “the command ‘…MGCB.exe…’ exited with code…”

I tried:

  • When I double click the Content file it opens up the MGCB tool and I can see the content tree fine and modify it. When I click Build it simply does absolutely nothing (output windows stays blank, like I didn’t click, same for clean).
  • When I open the MGCB application and then open the Content file from within the application I can build it just fine (all successful, also when cleaning and rebuilding, everything works fine it seems).
  • When copied the command from the Visual Studio error in CMD I got a message that FreeType6.dll couldn’t be loaded (a lot of people got this error). The DLL is in the same folder as MGCB (so it’s there). I installed VC++ redis 2012, 2013 and 2015 (as people suggested and which worked sometimes), but that didn’t help (I rebooted every time).
  • I installed all fonts I used for both the current (only) user on that pc and for all users, but that didn’t help.

A lot of people seem to get stuck with the content build. I don’t know where to look anymore. Does anyone have an idea on how to (try to) fix this in a systematical way? It’s annoying this error keeps popping up stalling projects.

Thanks for borrowing you brain!

It’s working! :slight_smile:

I followed the migration guide for MonoGame 3.7.1 to 3.8 and now it works again :). Migrating from 3.7 | MonoGame Documentation