MGCB.exe error code 1 with Skinned Model Processor


My intention is to have an animation in my Windows 7 MonoGame game by using fbx-files exported by Autodesk 3dx Max. Thats what I’ve done to animate a simple walking Biped:

  • Creating a MonoGame Windows Project using Visual Studio Ultimate 2013 with NET Framework 4.5 and MonoGame

  • Importing the SkinningSample.cs from the and adding and referencing the SkinnedModel project

  • Creating the SkinnedModelPipeline.dll and importing it to the MonoGame Pipeline to have Skinned Model Processor available:

The MonoGame Pipeline has successfully build the “Biped.fbx” with the Skinned Model Processor but when I try to compile my SkinnedSample Project I get the following error message:
Error 1 The command ““C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools\MGCB.exe” /@:“C:\Users…\SkinnedSample\Content\Content.mgcb” /platform:Windows /outputDir:“C:\Users…\SkinnedSample\Content\bin\Windows” /intermediateDir:“C:\Users…\SkinnedSample\Content\obj\Windows” /quiet” exited with code 1.

If I use the Model - MonoGame Processor it works fine but then I dont have the animation.

Does anyone has an idea how to solve this issue?

Many thanks!

I have this problem too. Did you manage to solve it?

Edit. Ran the command in the console without the /quiet flag. My fbx model had too many bones.

I have the same problem(((
I try to understand the problem for several months already…

Go to the ‘output’ tab and see if there is a more detailed error message from mgcb.

1 Like

THANK YOU :smile_cat:
It was a problem with my fbx model.