Missing references in UWP project

So I was thinking of porting my WP game to Windows 10. I created a UWP project in Visual Studio 2015 using the template in MG 3.5 beta. And I added all .cs files as link from my WP game project folder. Then I just realized that there are reference errors everywhere through out the App.xamal.cs file and the whole project.

For instance, the “using” directive below in the App.xaml.cs file is marked as missing references:

using System.Collections.Generic;

The error info says:

"Using directive is unnecessary.
The type of namespace name 'Collections' does not exist in the namespace 'System' (are you missing an assembly reference?)"

Also the App class declaration is marked as error:

sealed partial class App : Application

Error info:

"class Windows.UI.Xaml.Application
Encapsulates the app and its available services.

The type 'Object' is defined in an assembly that is not referenced. You must add a reference to assembly 'mscorlib, Version =, Culture=newtral, PublicKeyToken=b77a5c561934e089'."

I tried to edit the project references, but to no avail as I couldn’t find any of those references. I wonder if it is because UWP is using .Net 4.6?

Anyone knows the answer?

I tried creating a new MG Windows UWP project, and the same errors popped up right after the project was created. So I guess this is more of a problem on MG’s side?

I am getting the same problems attempting to create a MonoGame UWP App. VS2015 with Update 1 installed on Windows 10 1511 Nov Build. I used the Development Build today [MG 3.5 Beta ?] installer.

Edit: Spoke Too Soon !

Simply did a Build, and these red edit errors where resolved, so basic build does seem to work. References seem to become resolved following an attempted build.

This is caused by the new project system for UWP and .NET Core; it’s all NuGet-based, and therefore won’t have the necessary packages until you build it for the first time. Although I have no idea why this also affects built-in references.