MonoGame 3.5.1 VS 2015 CE Templates Fix

MonoGame 3.5.1 VS 2015 CE Templates Fix
Originally posted to the first link below, I am just sharing this as a thread to make it easier for me or others to link to the required help information.
Side note: I was not using any proof reading when I made those posts :stuck_out_tongue: and have added them here as originally posted.

To fix this all I did was open the template inside the templates folder with explorer; that is the zipped file.
Edited the WindowsUniversal.vstemplate file in Notepad [This can be tricky so set it [Notepad] as your default using an extracted copy and then try to open the zipped version inside the zip template]

Microsoft.VisualStudio.WinRT.TemplateWizards, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a

Delete that part near the bottom, you could probably do a Find with this exact phrase… if the token is the same… I made no other changes at all to the zip file contents [The file opens in notepad with everything running as a single line so will look a little messy].
Notice I included the trailing 4 spaces in that snippet. and for some reason the preview was showing the beginning ’ and < on separate lines but there are no spaces at the beginning of my snippet, and then just save it on closing the file.
Went to create a new project…
And viola, no more error message… project created successfully and compiled and ran. both debug and release.
Additional data: Windows 10AE Fully Updated, VS 2015 U3.

For those of you whom like a back story [As I do ]
I followed both mentioned methods above and neither worked…
However thanks to the contribution by parsec I was able to identify the precise issue at hand, following his/her method lead to no template option being shown… which is I presume due to the lack of whitespace, or that the zip required some other form of packaging? [Just a theory] Anyway I figured why not just isolate a particular part and it worked, somehow my subconscious decided to just edit the .vstemplate inside the zip file, kind of like IVF treatments no? haha.
Anyway I just felt I should contribute this method back to help others too.
Time to get coding!
Hope this helped,

I just did a fresh install of VS2015CE and MonoGame 3.5.1 and had the RT issue, used my above method this time allowing VS to open the .vstemplate file and just did as before and removed the reference.
OK! Found the actual issue, the WinRT token is included twice… did not notice this in word-wrap on notepad but I saw it in VS. so just remove one of the references.
Works like a charm.

I hope this helps,