MonoGame 3.5.1

We are very excited to announce MonoGame 3.5 is now available for download! Thanks to all the hard work from the community this is possibly one of the best releases so far.

UPDATE 3/30/2016: The original 3.5 release was updated to 3.5.1 with a few critical bug fixes.

We had tons of fixes and features in this release, but this is just a short summary of the major changes:

  • Content Pipeline Integration for Xamarin Studio and MonoDevleop on Mac and Linux.
  • Automatic inclusion of XNBs into your final project on Mac and Linux.
  • Improved Mac and Linux installers.
  • Assemblies are now installed locally on Mac and Linux just like they are on Windows.
  • New cross-platform “Desktop” project where same binary and content will work on Windows, Linux and Mac desktops.
  • Better Support for Xamarin.Mac and Xam.Mac.
  • Apple TV support (requires to be built from source at the moment).
  • Various sound system fixes.
  • New GraphicsMetrics API.
  • Optimizations to SpriteBatch performance and garbage generation.
  • Many improvements to the Pipeline tool: added toolbar, new filtered output view, new templates, drag and drop, and more.
  • New GamePad support for UWP.
  • Mac and Linux now support Vorbis compressed music.
  • Major refactor of texture support in content pipeline.
  • Added 151 new unit tests.
  • Big improvements to FBX and model content processing.
  • Various fixes to XML serialization.
  • MediaLibrary implementation for Windows platforms.
  • Removed PlayStation Mobile platform.
  • Added content pipeline extension template project.
  • Support for binding multiple vertex buffers in a draw call.
  • Fixed deadzone issues in GamePad support.
  • OcclusionQuery support for DX platforms.
  • Fixed incorrect z depth in SpriteBatch.
  • Lots of OpenTK backend fixes.
  • Much improved font processing.
  • Added new VertexPosition vertex format.
  • Better VS project template installation under Windows.

Note that we’re moving to a quarterly release schedule with 3.6 shipping in June. You can look at our milestones on GitHub to see the schedule of releases and our plans for the 3.6 release.

As always thanks for supporting MonoGame!

1 Like

awesome can’t wait to test it out. :slight_smile:

Great news ! Just hope that anything from 3.4 doesn’t get broken and it’s awesome!

Hey, is there a reason why WindowsUAP nuget package is not updated to monogame 3.5, but it is still available as 3.4?

“Mac and Linux now support Vorbis compressed music.”

What about wins? Last stable version of 3.4 had some issues here if I remember.

Windows OpenGL version (now DesktopGL) has vorbis support. DirectX version is sticking with wma.

It has been superseded by the correctly named “MonoGame.Framework.WindowsUniversal” package."

1 Like

Wooo, what a great release! It appears to have fixed an Song and MediaPlayer issue I was having that really bugged me. Keep up the great work!

Overall very happy with this update! But with the new version there is no longer a RefreshRate member in the DisplayMode class, and I couldn’t find an alternative parameter to get the monitors refresh rate now? I used it to lock the framerate dynamically to whatever the user’s display was capable of.

This was removed in in response to issue This includes a link to Shawn Hargreaves response to why it was removed in XNA 4.0.

To lock framerate to the user’s display, use PresentationParameters.PresentationInterval of PresentInterval.One.

I just installed it, and now none of my .fbx files will load whatsoever, and repeatedly give me this error (again!)

With 3.4 the error was a constant pain, but I overcame it with Autodesk converter. Now, not even that fixes it. I’ve imported it into the pipeline, into Visual Studio, tried every setting and nothing works! These are the same fbx models that I did eventually get working in 3.4 (albeit I couldn’t get them to have SkinnedEffect, which is why I was hoping the upgrade works).

Please help (I export from Blender). I know this is slightly off topic, but this has been an issue for me from the day I started using Monogame 3.4 and I would really like a definitive answer.

Can you post one of the models?

FBX Models

mod_debug.fbx - Very simple model. Has a texture applied. Worked before the move.
mod_stairs2.fbx - More complicated model. Has a texture. Worked before the move.
mod_lizard.fbx - Animated model with a texture. I managed to load it once (but the texture didn’t load for some reason). Monogame kept loading it without any SkinnedEffects.

2 of the 3 models you sent don’t have texture associated with them, and for the third one you didn’t send the texture…

Is that’s what’s causing it? I looked it up in Blender, and it turns out I just forgot to apply the textures to the material. However, I tried exporting a .fbx earlier without any textures whatsoever and it still didn’t work. As for the textures themselves, they’re just normal .png and .jpg files, but I guess I can send them if it helps.


That does not appear to work for me. I have a 144hz screen (and yes, I just checked to make sure, it’s properly running at 144fps for other applications) and with this I’m still getting a 60fps lock. Only setting “this.TargetElapsedTime = TimeSpan.FromMilliseconds(1000f / 144);” in the main game class works, but that would be a hardcoded limit.

Edit: Setting SynchronizeWithVerticalRetrace = false and PresentInterval.Immediate doesn’t work either, even though the documentation says “There is no limit for framerate.”

Edit #2: Resolved, I was running borderless window mode all along and my GSYNC wasn’t set to be enabled in windowed mode aswell (think I had some issues previously playing games in borderless window with other stuff on 2nd regular 60hz screen caused stuttering on that one, will see if it works with new drivers now)

On a different note: Am I correct that MSAA is still unsupported on Windows platforms for now? Looks like it has been moved to 3.6+ milestones.

I just downloaded some FBX viewers, and none of the 64 bit ones seem able to open any .fbx files (I have a 64 bit machine). They just freeze up before rendering anything. I did find a 32 bit one which opens them just fine. Don’t know if it helps.

Estou muito animado com essa nova versão! Parabéns a todos que participaram!!!

Project templates not getting added to the latest MonoDevelop (5.10) on Linux.

They are getting added for me, what Linux are you running? What do you get by calling “mdtool” from terminal?