MonoGame 3.5

I just installed it, and now none of my .fbx files will load whatsoever, and repeatedly give me this error (again!)

With 3.4 the error was a constant pain, but I overcame it with Autodesk converter. Now, not even that fixes it. I’ve imported it into the pipeline, into Visual Studio, tried every setting and nothing works! These are the same fbx models that I did eventually get working in 3.4 (albeit I couldn’t get them to have SkinnedEffect, which is why I was hoping the upgrade works).

Please help (I export from Blender). I know this is slightly off topic, but this has been an issue for me from the day I started using Monogame 3.4 and I would really like a definitive answer.

Can you post one of the models?

FBX Models

mod_debug.fbx - Very simple model. Has a texture applied. Worked before the move.
mod_stairs2.fbx - More complicated model. Has a texture. Worked before the move.
mod_lizard.fbx - Animated model with a texture. I managed to load it once (but the texture didn’t load for some reason). Monogame kept loading it without any SkinnedEffects.

2 of the 3 models you sent don’t have texture associated with them, and for the third one you didn’t send the texture…

Is that’s what’s causing it? I looked it up in Blender, and it turns out I just forgot to apply the textures to the material. However, I tried exporting a .fbx earlier without any textures whatsoever and it still didn’t work. As for the textures themselves, they’re just normal .png and .jpg files, but I guess I can send them if it helps.

Textures

That does not appear to work for me. I have a 144hz screen (and yes, I just checked to make sure, it’s properly running at 144fps for other applications) and with this I’m still getting a 60fps lock. Only setting “this.TargetElapsedTime = TimeSpan.FromMilliseconds(1000f / 144);” in the main game class works, but that would be a hardcoded limit.

Edit: Setting SynchronizeWithVerticalRetrace = false and PresentInterval.Immediate doesn’t work either, even though the documentation says “There is no limit for framerate.”

Edit #2: Resolved, I was running borderless window mode all along and my GSYNC wasn’t set to be enabled in windowed mode aswell (think I had some issues previously playing games in borderless window with other stuff on 2nd regular 60hz screen caused stuttering on that one, will see if it works with new drivers now)

On a different note: Am I correct that MSAA is still unsupported on Windows platforms for now? Looks like it has been moved to 3.6+ milestones.

I just downloaded some FBX viewers, and none of the 64 bit ones seem able to open any .fbx files (I have a 64 bit machine). They just freeze up before rendering anything. I did find a 32 bit one which opens them just fine. Don’t know if it helps.

Estou muito animado com essa nova versão! Parabéns a todos que participaram!!!

Project templates not getting added to the latest MonoDevelop (5.10) on Linux.

They are getting added for me, what Linux are you running? What do you get by calling “mdtool” from terminal?

I’m running Mint 17.3 Xfce, why? And what do you mean “what do you get by calling mdtool”? MonoDevelop Tool Runner is present in my system, if that what’s you wanted to know (I’ve installed all packages required).

Just run “mdtool” in terminal and tell me the output.

Well, duh.

Also, how do you uninstall it on Linux? There’s literally no hint on how to do that, and the 3.5.1 installer (I need to upgrade from 3.5) only tells “Please uninstall any previous versions of MonoGame SDK”. Oh, well, cool, I’d love to. But how? (don’t tell me I need to delete all files by hand or something, especially since I do not knowing their location)

sudo /opt/MonoGameSDK/uninstall.sh

Already found it, but thank you anyway. Also, still don’t get it: why you needed me to run mdtool?
P.S. I think I’ve been posting too much lately, should I delete [some of] my comments?

The issue turned out to be the fact I’m using ecryptfs.

I seem to be having a problem with the installer, when asked if I want to install the templates to visual studio the options are grayed out.

I just installed it. Why is it installing to C:\Program Files (x86)\MonoGame\v3.0? Shouldn’t it install to C:\Program Files (x86)\MonoGame\v3.5.1?

Nick it goes there for backward compatibility. Otherwise people would need to upgrade their project files all the time. It would be nice if Windows supported symlinks like linux that don’t require Admin rights.