MonoGame 3.7

MonoGame 3.7 is now available for download

Thanks to all the hard work from the MG developer community that made this release possible!

MonoGame 3.7 for VisualStudio
MonoGame 3.7 for MacOS
MonoGame 3.7 Pipeline GUI Tool for MacOS stand alone installer
MonoGame 3.7 for Linux
MonoGame 3.7 Source Code On GitHub
MonoGame 3.7 Assemblies on NuGet

You can read about the major fixes and features in the change log.

Thanks for supporting MonoGame!


Problem : custom content importer / processor not visible in pipeline tool after update to 3.7


@Tom What the hamburger, go take a coffee/tea break! :heart:


UWP Templates use target version selected in wizard. #5819 :heart_eyes:

Fixed back button problems in UWP. #5810 :heart_eyes:

Update the UWP Template to use the Latest SDK. #5931 :heart_eyes:

Upgrade to SharpDX 4.0.1. #5949 :heart_eyes:
¬-{ Is this issue circumvented?
¬-[ Any reason we are not using 4.2.0? [I know it was released/updated like a month ago, but is there an alternative reason?]
¬-[ For anyone wondering and

Update the UWP Template to use the Latest SDK. #5931 :heart_eyes:

So, which .NET versions are supported now? I mean, should I learn .Net Core 2 now or? I am pretty much well versed in 4.5

Should you uninstall 3.6 first or does that matter?

Uninstall it first, I think Windows installer might still not be fixed regarding this.

Awesome :slight_smile:

Thank’s for updating the PCL as well!

The change log is awesome :scream:

Yay, mipmaps work correctly on Android now! Thanks a lot guys, great release :slight_smile:

1 Like

Thank you MG developers for your work on the new release. Your work is really appreciated keeping this awesome project alive. Cheers :beers:

1 Like

Brilliant work MG guys!:tada:

1 Like

Way to go guys! Keep up the good work - can’t wait to try out the new bits!

Fantastic release, you guys rock!

no!, they !

1 Like

hahahah, very good :slight_smile:

1 Like

After installing 3.7 for Visual Studio, I made a new project and when I clicked on start before doing anything else I get this error.

Exception: Failed to load SDL library.

I also get the same error on existing projects.
I uninstalled 3.6 before installing 3.7. Was I supposed to do something else?

What is the current state of MonoGame and XNA’s

using Microsoft.Xna.Framework.GamerServices;
using Microsoft.Xna.Framework.Net;

As you can still run Games for Windows Live on Windows 10, but you cannot login to an online account(?). Are any of these libraries able to be ported to UWP and the like?

Starting in Monogame with great news :smiley:

Great work, everyone! :clap:

(Hey @Tom, just noticed this announcement still isn’t a “News” item on the main website!)
#MissingATrick :wink:

1 Like

Considering how little news we have, we’ve talked about removing that page in favor of the Twitter account.

1 Like