MonoGame 3.8 on Linux

Hello everyone

I recently updated from 3.7 to 3.8 (something like that) and I have noticed that my game does not run on Linux any more.

Now, I have created a new project (something like: https://docs.monogame.net/articles/getting_started/2_creating_a_new_project_vs.html, also in visual Studio 2019) and I have compiled it (like in the old times with MonoGame < 3.8). On Windows everything worked fine. Those are my created dependencies from Visual Studio and the MonoGame template:

So I went to my linux system where i used / still use to test my projects and ran into following message:

Cannot open assembly ‘testLinux.exe’: File does not contain a valid CIL image.

This sounds a bit technical to me. What do I do wrong?

Thank you
Andru

You have to install the .NET Core SDKs for Linux: https://dotnet.microsoft.com/download

Then you can do dotnet run.

I wrote some info here: https://learn-monogame.github.io/getting-started/

Hi Apostolique

Every command works except this one:
mgcb-editor --register

bash tells me: mgcb-editor: Command not found.

I tried it with .net 5 and .net 3.1. The installation of .net.core 3.1 seemed to work. When I type in
dotnet --version I get the correct answer : 3.1.404

Also:
dotnet tool install --global dotnet-mgcb-editor
seemed to work fine.

Kind Regards
Andru

Hi Apostolique

Well, even if the command " mgcb-editor --register" does not execute on my computer, i can run .dotnet applications now successfully.

Thank you.

Thanks for the feedback, I’ll have to note that. That command is meant to allow you to open.mgcb files with the GUI app. I guess it doesn’t work because you don’t have the dotnet tools directory in your path. https://docs.microsoft.com/en-us/dotnet/core/tools/dotnet-tool-install#description

On Windows that gets added automatically iirc.