MonoGame Crashes with exit code -1

A few days ago I tried to install the MonoGame framework but after following the steps from the “getting started guide” and creating a windows desktop application with the MonoGame framework I got this error

I do have a suspicion it may have something to do with Netcore as I had to get a different version of it to run MonoGame. I get the same error when building through visual studio or building through my console.

There is also this error which may corollate to the first one and some dependency issues


Things I’ve tried

-Deleting and reinstalling Netcore

-Installing MonoGame on another computer following the same steps (It worked without any errors on another computer)

-replacing the files from another computer to my main one (e.c Netcore and other ones)

-Trying to find a MSBuild folder that may have installed in the wrong place (wasn’t able to find one)

I also joined the MonoGame discord if anyone wants to chat or talk there. Any help is deeply appreciated!

Try my guide here:

1 Like

Hey I followed your guide and decided to make a fresh blank template. No errors so far! It doesn’t fix creating a template through visual studio having problems but for now its a workaround that works.

Thanks so Much!

1 Like

Did you see the SDK post below it? Day 1.5

Just checked it out. I think my issue might be a bit different, my template doesn’t fail to load it loads with errors. I did however get the SDK files you mentioned and opened the csproj file of a project I made with the templates provided but I wasn’t able to get a yellow box in my solution explorer that would let me install missing components. perhaps my computer is cursed

If you got the SDK, you will not see the install feature.