Monogame Framework not working (Ubuntu 16, Monodevelop 6.1)

Hey everyone, I’m really struggling with this :frowning:

Been looking online for ages now for an answer to this, but someone out there MUST be using monodevelop on linux and have monogame working. If so, what version of monodevelop did you use, and which version of monogame?

When I go on file > new solution > monogame app, the base project doesn’t even compile with the errors being around the Microsoft.XNA.Framework. After looking at the references, the Monogame.Framework reference is greyed out.

Any help will be really appreciate, spent all day trying to get this to work as I’ve just got ubuntu on my new laptop and I really want to continue making games.

As a side note- is monodevelop the best for monogame, or should I try a different IDE?


So after trying a little bit harder and browsing various posts on here, I am still a tad unsure what to do. Monodevelop 6 is out, and so I don’t know whether I should be trying to use that, or trying to use 5. The way to install 6 uses Flatpak, which doesn’t work with monogame or something (from what I’ve seen anyway, maybe this is outdated or maybe I misinterpreted).

Really would love to use 6 for the dark mode, sounds really picky, but I honestly hate the look of a light IDE, and 6 does work nicely with everything I’ve tried (except monogame). Right now, I have uninstalled everything, but the monogame sdk is still on my machine as I don’t know how to uninstall it (but installing it tells me to uninstall it first, so it is on here). I’ve done this so that when I do find the answer I have a fresh start. Thanks for reading and I hope we can solve this - if we do I will be making an in depth tutorial as it’s very frustrating when you just want to code but can’t :frowning:

I have MonoDevelop working fine, currently 6.1 and I’ve used a whole range of develop versions of MonoGame. Have you tried building from source? I’m on arch and found someone who hosted binaries for 6.1 so it was a bit of a search, but easy afterwards.

MonoDevelop is the only IDE available on Linux that the MG installer currently installs templates for, so it’s good to have if only for that. There is a standalone project generator in a PR somewhere too.
In terms of other IDE’s, Visual Studio Code with C# plugins is pretty good and I’m a fan of JetBrains so I’d recommend Rider which is in public early access and therefore free for now. Code has a dark theme by default I think and Rider has the Darcula colorscheme :heart_eyes:

Thankyou for reigniting my spark of hope for getting this to work!

I have not tried building from source, but I am new to Linux (and programming in general I guess? At least, with this kind of stuff? I know C# at least :stuck_out_tongue: )

Would it be okay if you could give me some pointers as to how to do this in detail so I dont mess it up?Im sure I can find it online if not though. Also, did you use the add in from here?

Or did you implement monogame into monodevelop another way?

Going to sleep soon so if I don’t reply I’ll get back to you tomorrow with my findings! <3

Yay, enthusiasm :smiley:

Instructions are in the README on the GitHub page: GitHub - mono/monodevelop: MonoDevelop is a cross platform .NET IDE
I installed the templates by running the MG installer after installing MonoDevelop. The latest develop installer tells you if it can find the MonoDevelop installation when it lists dependencies at the start.

so should I download the last non-failing build? :slight_smile: and ah okay, I think I did install that, I wonder if it will work even though monodevelop isn’t installed yet, should probably see if I can uninstall it to ensure it doesn’t mess things up?

Hey there, so I’m currently building monodevelop from source and I realise this is now a monodevelop issue more than a monogame issue, but it’s worth a shot.

These are the results I am getting when trying to run the ‘make’ command after doing ./configure --profile=stable :

make make[1]: Entering directory '/home/ashley/Downloads/monodevelop-master/main' Making all in external make[2]: Entering directory '/home/ashley/Downloads/monodevelop-master/main/external' make[2]: Nothing to be done for 'all'. make[2]: Leaving directory '/home/ashley/Downloads/monodevelop-master/main/external' Making all in . make[2]: Entering directory '/home/ashley/Downloads/monodevelop-master/main' if test -f "./buildinfo"; then cp "./buildinfo" "./build/bin/buildinfo"; else ./../scripts/ gen-buildinfo "./build/bin"; fi /usr/bin/git failed Makefile:1151: recipe for target 'build/bin/buildinfo' failed make[2]: *** [build/bin/buildinfo] Error 1 make[2]: Leaving directory '/home/ashley/Downloads/monodevelop-master/main' Makefile:676: recipe for target 'all-recursive' failed make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory '/home/ashley/Downloads/monodevelop-master/main' Makefile:31: recipe for target 'all-recursive' failed make: *** [all-recursive] Error 1

I really am out of my depth here team :confused: didn’t know how hard it’d be installing something like this.


Okay, scrapped everything and followed this guide:

Thanks to the folk on Monodevelops gitter for showing me this. It all works.

Okay. I made a big mistake. After getting it to work, I decided to move the files to a different location, and it broke EVERYTHING. And now, I cannot even repeat the steps to fix it. I am getting these errors


/home/ashley/Applications/MonoDevelop/ (default targets) ->
(Build target) ->
/home/ashley/Applications/MonoDevelop/ (default targets) ->
/usr/lib/mono/4.5/Microsoft.FSharp.Targets (CoreCompile target) ->

FSC: error FS0193: The module/namespace 'Gdk' from compilation unit 'gdk-sharp' did not contain the namespace, module or type 'EventClient'
/home/ashley/Applications/MonoDevelop/,6): error FS1109: A reference to the type 'Gdk.EventClient' in assembly 'gdk-sharp' was found, but the type could not be found in that assembly


What the f is going on :frowning: I had this working and I got cocky I guess. It debugged and everything, I’m so sad :confused:

Long story short, @harry-cpp and I did a lot of work, and found that the git addin was one of the reasons everything broke. If you’re reading this and you’re as lost as I am, hit up the gitter chat (found on the main github page) and talk to everyone, or try disabling your git button.

Good luck, you’ll need it :smiley:

Thank you Crysikrend

Thanks to you I found a way to install MonoGame on Xubuntu 16.04.01 LTS (ubuntulike). The key was to install from scratch Monodevelop 6.1.XX by ur Post