MonoGame Pipeline build failures.

I’m using Monogame 3.7.1 with VS 2019 for a class. I’m following the tutorial at this address:

but I can’t get the Pipeline Tool to build when I select my images. I have looked through many forums looking for an answer. I tried to download old versions of the C++ redistribute, but the installer said no download was necessary. I am using Windows 10, and have my Configuration Manager set to x64, because I thought there was an issue between 32 bit OS and 64 bit OS. Any help is greatly appreciated.

Hi @RossXVII, Welcome to the forums,

Now, there are several methods to use the Pipeline Tool, are you using code or are you using the file inside VS, it sounds like you are using the file inside VS, so, have a look at using the actual tool instead and see if you still have issues, I have guides on using it properly if you need them, just look closer at my profile and you should find them.

Happy Coding!

Do you see a gui window for the tool when you double click the orange icon ?

Are you asking me or him?

Him of course.

That tutorial is pretty basic the only thing missing on the page is a picture showing how to add your content. But the previous tutorial basically explains it.

1 Like

Hey, thanks for the response. Yes, I saw that tool under content. When I double clicked it I could add existing files to the content, but building always failed. I found a youtube video ( 18:29) where the programmer went through this process, but I didn’t have a bin folder.

The issue, I think, was I tried to add the 2017 templates from this github page: but I don’t think the Pipeline could actually see the content I was trying to add.

I’m going to do a fresh install as they do in the youtube video. Thanks again for commenting, I may yet be back.

Have you tried using the tool independently yet?