Monogame Sources via Git / ProtoBuild

Hi !
I tried to get sources from protobuild.exe but i always get a code 128 when trying to build for windows.
Cloning from git under visual 2013 doesn’t provide *.csproj nor *.sln
Did i miss something to be able to build the dll myself ?

In order to be helped as bast as we can, you have to provide EXACTLY what you have done and haven’t done, not what you THINK you have done.

I also build MG dll and tools using protobuild, what I did:

  • download source (either mere download or clone github repository then sync from time to time)
  • open a cmd, run protobuild.exe -generate (this step actually create projects for the target platform, default = running platform)
  • then protobuild.exe -build
  • then copy the relevant dll somewhere else, with the needed tools and use them (or try to).

Hope this help.

I did this:
download the source.
opened cmd.exe:
I changed the path to the folder of the unzipped monogame-develop folder, launched protobuid.exe --generate Windows
And then I got this error code 128.

So i tried to clone under visual studio from Team Explorer > Connect Local Git.
I then clicked on Clone, entered the https url, and the folder to put the files in (mymonogame for ex).
And then when i open mymongame folder, and launch from a command prompt (admin rights or not it is the same result)
protobuild.exe --generate (1 or 2 - does not change anything)
I still get error code 128.

My folder is under a different drive (i:) than the installed windows drive (c:) can it be the source of problem when protobuild does:

Cloning into ThirdParty/Kickstart…
fatal: failed to open ‘/cygdrive/i/xMonoGame/MyMonogameMASTER/C:\Users\Alkher\AppData\Roaming.protobuild-cache\af4406f790ebfd18b4fa28d2ae279677bce38053–source/objects’: No such file or di
System.InvalidOperationException: Got an unexpected exit code of 128 from Git

EDIT: I have move the folder to my c: drive, and launched the command prompt, protobuild.exe -generate still gives code 128
EDIT 2: It seems to be related to git or repository:
0 [main] git-remote-https 19960 child_info_fork::abort: data segment start: parent(0x5D5000) != child(0x345000)
error: cannot fork() for fetch-pack: Resource temporarily unavailable
System.InvalidOperationException: Got an unexpected exit code of 128 from Git

Yep, you didn’t tell about the use of cygwin, which may is more important than you think. and error 128 comes from git itself, try first the git command line, you may also try wget/curl/other net tool to see if your cygwin environement (I presume) have a working network access.

Is cygwin a prerequisite to build monogame ? I’ve never installed it… it may be the source of the problem.
But on Windows requirements are empty…

There is no Cygwin required… ever.

The process on Windows is

  1. Clone the Git repository. Easiest way is via TortoiseGit or Git command-line.
  2. Update Git submodules.
  3. Run Protobuild.exe (simply double-click the exe, no parameters needed for default behaviour) to generate the .sln and .csproj files.

If i try with TortoiseGit, i get
git did not exit cleanly (exit code 3328) (218 ms @ 19/04/2016 13:38:22)

I think i’ll try on another computer, maybe this one is too messy…

EDIT: i have restarted the computer and now it downloads… crossing fingers (and toes may help :wink:)

All went ok. Just a restart of the computer seems to have fixed it…
Thanks for your help