Monogame Templates on MonoDevelop Not Creating Project

I’m at the last step before I get to try Monogame out and I am having a problem with the monogame project creator on MonoDevelop.

I’ve installed MonoDevelop-alpha using flatpak as that is the recommended way to get MonoDevelop on openSUSE, I have all required dependencies, as shown when I re-run the installer. (I have the MonoGame Pipeline Tool)


  • mono-runtime…[Found]
  • gtk-sharp3…[Found]

Optional Dependencies:

  • MonoDevelop 6…[Not Found]
  • Rider…[Not Found]
  • referenceassemblies-pcl / mono-pcl…[Found]
  • ttf-mscorefonts-installer / mscore-fonts…[Not Found]

My version of MonoDevelop is 7.2.2. I have installed the monogame addins for MonoDevelop 7. I click on New Solution in MonoDevelop and in Miscellaneous I see “MonoGame Solution/Project” I click on that and hit next. I name the project and choose a directory and then click on Create. My problem is the window sticks on create like it is waiting for more input. I watched a youtube video and I see that when create is clicked another window should pop up to create the project. This window does not display on my computer. All I see when I click create is the same window. I can click on cancel and see that a folder was created that contains an empty folder, a .sln file, and a .userprefs file.

My guess is that the problem may be because of flatpak. I’m not knowledgeable on the tool as I just installed it earlier to get MonoDevelop on my computer without having to build from scratch, but I remember reading that it is basically a sandbox for applications. Could the way flatpak runs be blocking a new window from being created? Has anyone dealt with something like this before? From what I know I have everything installed, the problem is just this creator. So if nobody has a solution could someone direct me to a github repo or the like to use as a project builder. Is it in the works to have an official project creator like the creator for LibGDX?

Sorry for the long question. Any help will help.



You need specifically MonoDevelop 6 for the templates. Also flatpak version will not be able to run MonoGame projects.

Read up: Installing MonoGame 3.6 on Linux

I read that before posting and assumed that the package you provided could be replaced by the newest version of monodevelop but I was wrong at that I see.

I followed your instructions, I installed mono and monodevelop, I opened monodevelop and compiled a project just to make sure all was in place. I then built your github package using your directions. I got an error stating that glib-sharp2 could not be found. I then installed glib-sharp2, which was available with my package manager. Now when I run your package, monodevelop-stable, I get no error like I did when I didn’t have glib-sharp2, It shows me running the command, a second goes by, and then my terminal shows my user name like it is awaiting a command. So it crashes without any errors to the console.

So this is what I did to accidentally got a monogame project RUNNIN!

I installed the MonoDevelop6 source from here

I ran ./configure and it said I needed msmerge, which is available through the below command on openSUSE.

sudo zypper install intltool

Running configure again showed me that I needed to install gtk-sharp-2.0, which I had v3 not v2.

sudo zypper install gtk-sharp2

I then found that I needed glade-sharp-2 which my package manager did not have, BUT I went back and ran your monodevelop-stable package and it ran this time!

I removed my monodevelop source and opened your packaged version. All worked perfectly, though there is still problems building F# applications or applications that require an external console, but I’ll take it!

Thanks again for your package and for being active on here. I tried to be thorough with my process to help others if they run into anything that I did.