Monogame & Visual studio 2017


I installed visual studio 2017. I can’t create a new project Monogame(it doesn’t appear on the list).
before, I used Visual studio 2015 and all was OK.

What can I do ?


Did you run the installer again?

Windows 10, right?

Also you need the I think 10240? Windows SDK…

Did you make the correct template selections during the installation process (vs 2015 & vs 2017)?

If not, re-install the MonoGame framework and make your template selection for VS 2017…

I have had this issue on my work PC, but at home is was fine. At work I need to enter a local admin username/password in order to allow it to install and I found the templates in the local user admin’s Documents\Visual Studio 2017\Templates\ProjectTemplates\Visual C#\MonoGame directory, so I just copied them to my user account and everything was fine.

I had this issue with Windows 10 Home (German Language) and VS 2017 Pro. Can’t remeber the VS 2017 Web Installer Version but it creates the default template folder with \user…\documents. But in my german language Setup from Windows the folder is called \user…\dokumente. The MonoGame 3.6 Setup creates the templates in the correct folder \dokumente\ but in the VS2017 options for projects and folder was the wrong path. To change this template path in the VS2017 Settings helped me out and i could create new MonoGame Projects.