MonoGame VS2013 Templates not working under W10 Preview


I guess I am expecting too much. But I downloaded and installed the VS2013 Community Edition (Technically the same as VS2013 Pro apparently) on a Windows 10 Tech Preview, Build 9879.

However I get Template errors when I Try to create a MonoGame Windows Store Project. I installed MonoGame Version 3.2 Windows Installer Templates for Visual Studio. I get the following error on Windows Store Projects:
"Error: this template attempted to load component assembly 'Microsoft.VisualStudio.WinRT.TemplateWizards, version, culture = neutral, …

I guess I have to wait for the next Windows Installer Release from the awesome MonoGame team, if Windows is still being supported.



We haven’t done any testing on the new community editions of VS, but we need to.

Still not sure if your issue is because of the Community Edition or if the issue is Windows 10 related.

It’s not WIndows 10 related, I have Win 10 and VS 2013 express and everything works.

hmm well that’s interesting.

The VS Community edition is now being touted as being a replacement to the VS Express editions, and for being functionally equivalent to the VS pro editions (only licencing being different).

My suggest is using repair on visual studio and reinstalling MonoGame.

I tried a VS 2013 Community Repair, and Re installed the MonoGame 3.2 Templates. But it did not solve the problem.

Looks as though a Template Problem with Community Edition not liking MonoGame Templates.

I can vouch that community Edition works with the Monogame 3.2 Templates. Although Windows 8.1 phone require latest sources.


How did you get around the above template problem in the Community edition. The error is not obvious.