MonoGame Win 10 Universal Template fails to load in VS 2017

The Windows 10 Universal Tutorial Microsoft provides a finished/compilable/deployable MonoGame:

which works fine when run in VS 2017 Community

But when I try to do the tutorial step by step, the Win 10 Mono Universal template (3.6 latest version using Visual Studio 2017) fails to load with a cryptic message about a Windows RT assembly. Then future attempts to use the template simply fail w/no detail just saying project creation failed

I’m having the same problem here. Have you found a solution to this at all? I’ve been searching all around the internet and found nothing worthwhile.

This is a known issue. Get the latest development release of MonoGame and it should be fixed. This is my source:

Thanks for the link! It worked after a few extra things I had to do.

With the help of @mikehaggar’s link to a blog post about MonoGame, I was able to figure out a full solution to this that has worked for me. I’ll be posting up the methods I used, and hopefully, they're of some help to everyone who might be having this problem.

As this blog post on says, this is a problem with Visual Studio 2017 being installed without VS 2015. It is an odd problem, but the problem was not patched before MonoGame 3.6 was released. Instead, the patch for the problem was done in the development branch, which you can download from this link to MonoGame's download page for the current development build.

Before you install the development build, I would recommend uninstalling MonoGame 3.6 and then deleting the templates from “C:\Users\<username>\Documents\Visual Studio 2017\Templates\ProjectTemplates\Visual C#” by deleting the “MonoGame” folder inside, as well as deleting the folder of the same name from your cache located in “C:\Users\<username>\AppData\Roaming\Microsoft\VisualStudio\<version_number>\ProjectTemplatesCache\Visual C#This last step of deleting from the cache was crucial to get it working for me!

After this is done, proceed with the installation of the development build of MonoGame, making sure to install the Visual Studio 2017 templates. After this, you'll be good to go with project creation, but there may be a few more things you need to do.

When I went to create the project, it would not let me create a project using the Creators Update template, giving me an error message saying:

Package Installation Error

Could not add all required packages. The following packages failed to install from 'C\Program Files (x86)\Microsoft SDKs\NuGetPackages':

Microsoft.NETCore.UniversalWindowsPlatform.5.1.0 : Unable to find version '5.1.0' of package 'Microsoft.NETCore.UniversalWindowsPlatform'.

The project ended up being created, but with errors galore, and it wouldn't allow me to download said package through NuGet. If you get this working with the Creators Update template, let me know, but otherwise, using the Anniversary Update template will work.

Once the project loaded using the Anniversary template, it may look as if it has the same errors as the Creators Update template problem, but simply go to NuGet package management and update the Microsoft.NETCore.UniversalWindowsPlatform package to the latest version, and you should be good to go!

I'll say again, though, that this is what got it working for me. I have no idea how this will work on other systems. I hope it works, though, and I wish you happy coding!

1 Like

This worked for me. Thanks a lot.

Just look through my posts here…