No Content Pipeline appears when d-clicking Content.mgcb


First time downloading MG 3.8.0, using VS 2019. Tried to bring up the content pipeline by double-clicking on the Content.mgcb file (in Solution Explorer) yet it doesn’t appear. However, a a new tab in VS2019 appears showing a set of Global Properties.

Note: I’ve already registered and installed the MGCB editor using:

dotnet tool install -g dotnet-mgcb-editor
mgcb-editor --register

How can I get the Content Pipeline to appear // or associate with the content.mgcb file?

-Microsoft Visual Studio Community 2019 (Version 16.5.1)
-MonoGame 3.8.0 (first time I have installed it)

Hi @lookingforslickmode , slick name! Welcome to the Community!

Without coming across a little, patronising, but have you tried right clicking it and ‘opening with’?

Happy Coding!

1 Like

This is due to a VS 2019 issue - there is a workaround for it previously here:

(it helps to search the forum :wink:)



Many thanks - that did the trick.

((I did about 15 - 20 minutes of searching the forum first before posting here. I was searching terms like “Content Pipeline not opening” & “Visual Studio won’t open Content Pipeline”. Hard to articulate at times when you don’t know what the issue is.))