Nothing happens when I try opening content.mgcb

I have a fresh install of Visual Studio 2022 and I installed the monogame extension. The MGCB editor is set as the default in the “Open With” menu, but nothing happens when I try to open the content file. Any help?

Did you try rebuilding the NUGET cache?

Not sure if I did it correctly, but I clicked the “Clear All NuGet Storage” button at Tools > Options > NuGet Package Manager > General and nothing changed.


Repair Visual Studio | Microsoft Learn

Did that. Still nothing :confused:

I forgot where the NUGET install is right now but someone may come by and explain how to use it that way, in the mean time, did you perform CornflowerBlue Hello World yet?


Oh… and Welcome to the Community @Oofator!

Happy Coding!

Sorry, I don’t really know what you mean by CornflowerBlue Hello World but the game runs fine if that’s what you’re asking.

Also thanks! I hope I can fix my issue because monogame really is awesome. :slight_smile:

1 Like

You can try to set it up with the command line first.

See if that works.

1 Like

Thank you! It worked through the console, and now it works on visual studio too. Even on new projects made with visual studio? I don’t know what changed but I’m glad it works now.