[Partially SOLVED] When I update the code and debug, the changes aren't applied.

I’m developing an Android game using Visual Studio and Monogame. Whenever I rebuild the solution and debug after making changes, the changes don’t seem to apply and it’s still running the old code. Does anyone have any idea why this would be happening and how to fix it? It’s driving me insane and has put a halt to all progress.


Click Rebuild/Clean buttons…

Or it could be something else… not an Android Dev so … yeah…

Yeah, I tried that. I’ve found a work around. In the emulator if I uninstall the app before rebuilding it seems to work every time. A little more time consuming than I’m used to with Visual Studio, but at least I can continue.

With Windows Phone I have the option to reinstall the app each time automatically, is there no option for that somewhere?

There is, and I’ve had it turned on, but it didn’t seem to make a difference. Broken maybe? I don’t know.

Are you using Visual Studio 2015 CE?

Yes I am using visual studio 2015 CE

Hopefully someone is familiar with this issue…

Go to Android Build Options and disable “Fast Deployment”. For whatever reason, this options doesn’t work properly with Monogame.