Pipeline.exe immediately exiting in latest MonoGame 3.8.0 builds?

Yesterday I upgraded from MonoGame to (Windows 10), and found that the MonoGame Pipeline tool (pipeline.exe) no longer works.

Double-clicking an .mgcb file from Visual Studio, or manually running pipeline.exe from \monogame\v3.0\tools, just “thinks” for a brief moment and then exits, without ever displaying any UI to screen. It seems broken in (the current build) as well. I’ve tested on two machines and the behavior is the same.

Reinstalling the older version ( gives me a working Pipeline tool again.

Let me know if there’s anything I can do to help debug – I tried running pipeline.exe from a powershell window but it didn’t appear to print out anything useful to console. Let me know if there’s a place I should be looking for logs or error messages.

EDIT: the official 3.7.1 release also works fine, of course.

Yes, I am seeing this also. Looks like the pipeline tool is broken.

Yup, still broken. Also, it seems like the periodic MonoGame dev builds are broken – it’s been over 3 weeks, but the latest installer version is still

This had me scratching my head for way too long! Rolling back to 3.7.1 fixed for now.

This problem seems to be a carryover from what I had going on with a Fresh Install of 3.7.1 on a new machine, and noted in this thread Cannot launch the pipeline tool on Windows 10:

That one was causing the same behavior with a WerFault (If you check Windows logs). Any possibility two people are building that code base with one setup badly? Because it seemed like if going to 3.7.1 was an upgrade it worked fine (Maybe did not overwrite Pipeline.exe), but on fresh install it was broken. My guess is forced overwrite of Pipeline.exe in -> upgrade, maybe same underlying WerFault?