Pipeline.exe not opening [Resolved]

Hi All

I’ve recently starting using MonoGame to create a small windows game. The content pipeline application was working fine for a couple of days until today all of a sudden it doesn’t want to open anymore. If I double-click on the icon in the solution explorer nothing opens. I’ve browsed to \MSBuild\MonoGame\v3.0\Tools try and open it directly but also no joy. I’ve uninstalled MonoGame and reinstalled it (v3.5.0.1678) and still it doesn’t work. I can’t find any log or error message to debug it. Have anybody else ran into this issue? Any assistance would be appreciated.

@harry-cpp - Doesn’t the pipeline tool open a config file on startup? What is that named and where is it stored? I wonder if that is failing to load and silently closing the app.

Yes it does, it’s stored in isolated storage ( http://stackoverflow.com/questions/275536/where-is-net-isolated-storage-stored ) with the name “Settings.xml”.

It was opening the config file until recently. If I create a new solution without modifying anything it still doesn’t open. Everything is located within their standard folders upon creation. Im currently away from my pc and will only be able to respond within a couple of hours.

When you get back try deleting that Settings.xml and see if it suddenly starts opening again.

Yay! That was the problem. I’ve located the isolated storage and tried to open the Settings.xml with Notepad++ but it complained about the XML Format. I’ve deleted the file and the Pipeline app recreated it and it now opens again. It seems like the XML got corrupted somehow. @Tom and @harry-cpp, thanks for your quick response and assistance, it’s really appreciated.

@harry-cpp - Looks like we need to protect against that and not crash out and fail to start.