Problem with Content Project

Hey all,

i have created a small project and wanted to work on it now on another computer. So i pulled the repos from git and now it says that the content projects are not compatible and dont work. I searched for 2 weeks now and did not found a solution. I also reinstalled visual studio 2013, installed xna 4.0 …installed monogame…and did all the template fixing to make them work, but it doesn’t load the content projects. Every other template is working, but as i pull and existing content project or create a new one, it gives an error.

check the referecnes the project will be compatible if and only if they have the same

make sure it’s not xna references but monogames references etc. etc.
you must check the referenes in the solution explorer

everything is loading, except content project with the *.png and *.wav files.

My windows dx game project has a reference to the game content project which holds a reference to the game content (content) folder where i added all my files. or did i something wrong?

You must understand I don’t understand your problem but I know some wisdom.

If the CODE has no errors besides content folder then you MUST look at how you deal with errors differently.

if it just almost compiles but does not run then you MUST make sure the assets are fine.

That is the wisdom.

Second wisdom.

Make sure you understand this

variable = Content.Load(“texture”);
variable = Content.Load(“spritefont”);
variable = Content.Load(“song”);
variable = Content.Load(“song”);

the second place the error could be is the load content method as it is a FACT the the #1 load content error that developers have is the fact that within the or or or content files they are not set right
maybe a spritefont is named a texture or a texture is a spritefont. check that as well.

hope this helps!

no :frowning:
did not help at all cause my problem is not getting clear (it has not to do with any line of code) and i dont know how to tell you, but i keep trying :smiley:

Computer A:
VS 2010, 2012, 2013
XNA- Working perfect
MonoGame- Working perfect
Game project i am developing- Working perfect

Computer B:
VS 2013
XNA- Working perfect
MonoGame- cant create content projects
Game project i am developing (after cloning it from GIT)- content project incompatible so it is not loading properly --> project not working

i would add a picture…but i cant cause i am new user…(how retarded is that…)…so remove spaces :smiley: 3lswbkE . png


problem still not solved.

does monogame require vs2010 to be installed? or the classic XNA 4.0 to be running properly?

Push, I have the same problem.

Windows 8.1
Visual Studio Professional 2013 Update 1
XNA 4.0: works
MonoGame 3.2: Can’t create content projects, can create other MonoGame projects.

Did this get resolved? I am having the same problem (unable to create content projects)

Note for future searchers: This can be solved by installing