Problem with loading a simple 3d model

Hi, recently I upgraded my project from MonoGame 3.2 to 3.3 and spotted a problem that I can’t handle.
When I try to load a simple 3D model (.fbx) in LoadContent(), an error appears: “HRESULT: [0x80070057], Module: [General], ApiCode: [E_INVALIDARG/Invalid Arguments], Message: The parameter is incorrect.”.
Does anyone know how can I load my test model without any problems?
PS. This is just a simple Windows project.

Seems like MonoGame 3.3 pipeline doesn’t like .fbx files created in Blender and converted to 2013 FBX in FBX Converter.
My solution was to import my model to 3ds Max and export it from there.

Can you post (or send me) the .fbx file exported from Blender? I would like to investigate why it is not working. Perhaps it is something that can be fixed in the content pipeline.

It’s just a simple textured model, converted to 2013 FBX format with this utility:

1 Like

Have you tried exporting the model with the latest version of Blender? The current version of Blender exports FBX 7.4 (= FBX 2014). Therefore, it shouldn’t be necessary to convert the model using the Autodesk FBX converter.

I’m using Blender 2.72 (newest is 2.74) and it also exports FBX 7.4. When I try to load model to MonoGame Content I get an error: “Assimp.AssimpException: Error importing file: FBX-DOM unsupported, old format version, supported are only FBX 2011, FBX 2012 and FBX 2013”, so maybe it’s that I’m trying to use FBX 2014 that is not supported by Assimp? :smile:

That could well be it. Can you try converting to an older format using the Autodesk tool?

I have just tried that and it works perfectly for versions mentioned in the error - FBX 2011, 2012 and 2013.
So I’ll stick to the 2013 version and thanks for your support. :smiley: