Problem with MonoGame 3.4 in Ubuntu 14.04.1

I’m attempting to install MonoGame 3.4 on Ubuntu 14.04.1. First I attempted to follow the steps from the documentation.

Everything went alright until I got to this part:

cd Downloads
chmod +x
sudo ./

There is no file until after I add run permissions to and inside the Makeself directory, then run Even then the documentation is incorrect because the file generated is called, not

I’m not quite sure why the documentation is unclear about those things. Am I missing something, or does the documentation need to be fixed?

Then I run into a real problem when I try to run as root:

Verifying archive integrity... All good. Uncompressing Monogame Pipeline Installer................................................................. ./ 1: eval: ./ Permission denied

This error persists even after I add run permissions to the file inside Data/RUN.

I’d appreciate it if anyone could help me work this problem out.

I also tried to install MonoGame by building the source. Following the steps, everything seemed to be successful until I opened MonoDevelop (v 4.0.12) to try it out. There is no add-in for MonoGame projects and I can’t add it from the add-in manager, or any file present in the repo.

So I think my problem could be resolved in one of two ways:

  1. Fix the error when installing from the release build
  2. Help me with the MonoDevelop add-in for MonoDevelop 4.0.12 after building MonoGame from source.

Thanks in advance for any answers! I’m excited to get started with MonoGame.

I’ll update the documentation a little bit later today…