Problems building content with Aether Extras

I have added some .fbx models to the content manager, and I can easily get it to work using the normal processor “Model - Monogame”. But when I change to the processor “CPU AnimatedModel - Aether” or “GPU AnimatedModel - Aether”, I always get the same kind of problem.

I’m not really sure what the problem is, I was following a tutorial online to get 3D animations to work, but the video does not cover this problem.

Do you get any kind of error message? I don’t see one in your post, but it might be under the collapsed model listing in the right pane

Getting no error message at all.

Also, when trying to build the code, it just points to the content manager with some generic description.

Edit: To clarify, there are no error messages under the collapsed model.

To add some information, I am using the latest version of Monogame (3.8).

Can you copy paste the text in here if you change to text output? Click View > Build Ouput > Filter Output

I think I have seen that before somewhere.
At the end it says ‘1 Failed’ and at the same time all items are Green/OK. If something has failed then the icon should have been Red. You can open an issue in github, and revert back to MG 3.7 until it’s fixed.

Did as you said and seems you can get more information this way, nice:

Skipping C:/Users/SlaktarMicke/source/repos/3DProj/3DProj/Content/Fonts/font1.spritefont
Mesh 0 has no skinning information, so it has been deleted.
Input skeleton not found.
Skipping C:/Users/SlaktarMicke/source/repos/3DProj/3DProj/Content/Models/pistol.fbx
Skipping C:/Users/SlaktarMicke/source/repos/3DProj/3DProj/Content/Models/skydome.fbx
Skipping C:/Users/SlaktarMicke/source/repos/3DProj/3DProj/Content/Models/skydome.jpg

Build 3 succeeded, 1 failed.

Time elapsed 00:00:01.33.

So, could this be reason as to why it is not working?

“Mesh 0 has no skinning information, so it has been deleted.
Input skeleton not found.”

“Mesh 0 has no skinning information, so it has been deleted." is a warning.
“Input skeleton not found.” is an exception/error.

Try to set FixRealBoneRoot=true in the processor to see if that can fix it.

1 Like

There might be a problem with the models that I have been trying. I downloaded a model instead, and it worked.

FixRealBoneRoot=true did not fix the problem for the model that had problems.

I seem to have another problem now, the models ModelMeshParts does not have the method UpdateVertices for some strange reason…

Tried this but doesn’t work:

part.UpdateVertices(_animations.AnimationTransforms); // animate vertices on CPU


Actually never mind that problem with UpdateVertices, just me being stupid there!

Everything seems to be in order now, thanks for the help. :slight_smile:

1 Like