Project won't build on Mac OS after adding fontsprite through Pipeline.

I am running MonoGame 3.6 on Mac OS 10.13.4. I can successfully add images through the Pipeline GUI and the app builds fine. However, after I add a spritefont through the GUI, I get the following error at build:

Error: Processor 'FontDescriptionProcessor' had unexpected failure!

I am starting with something simple, so I added ArialRegular.spritefont file to Content/Fonts through the Pipeline GUI, then opened the file to edit the FontName attribute. I changed the attribute to Arial-Regular.ttf. I included the ttf file in the same Font folder as the spritefont file. When I try to build, I get this error.

Things I have tried:

  • Changed the TextureFormat from Compressed to Color
  • Imported the spritefont and ttf files into the project
  • When importing alone failed, changed the Build Action to BundleResource (also tried Content)
  • Tried to download the latest Pipeline development build from, but for some reason the links fail for me.
  • Thought to move the XNB file to the build folder, but then found that an XNB file is not being generated.


  • Could I move the project over to VS 2017 on my PC and perform these XNB operations, then bring the project back to Mac to continue development? I don’t like jumping through those hoops, but if it is a viable workaround I’ll take it for now.
  • Am I just missing the obvious? I’ve read through the documentation, but maybe there’s some other steps involved for Mac?
  • Is there a manual way to add content to the project without using the Pipeline?

Thanks for any input!

Is it possible for you to upgrade your MonoGame version to a 3.7 development build and try that? I’ve never used the tool on OSX, but there have been many fixes since 3.6 was released.

Unfortunately the download links don’t work for me, I’m not sure why. I am in the process of trying to get the development repo to build locally now, but if someone could figure out why the links don’t work that would save me a lot of time.

I think the build machines are still down, which explains it; hopefully they’ll be up soon.