Running MonoGame with Microsoft.Android Game Constructor Null Reference Exception

First of all this is NOT a “How do I run this with .NET MAUI” question. :slight_smile:

Ok, with that out of the way, I’m trying to wire up MonoGame with NET 6 and the new Microsoft.Android and Microsoft.NETCore.App Frameworks.


I take an existing template (with Mono.Android, System, System.Core, and System.Xml) build it, and I’m good to go.
However, when I use Microsoft.Android, the program crashes on the Game1 class constructor. Null reference exception.


Was wondering if anyone has been playing with the new Microsoft.Android bits and has this working?

Can you tell us what, specifically, is null? I assume it is something down in the Game base class’s parameterless constructor, but I might have more ideas/suggestions if I knew what thing, specifically, was unexpectedly null.

I’m not sure how. When I click view details I get the QuickWatch windows but I’m not sure where to look (or how to send the whole thing over). If you can give me steps I’ll surely do them:

The other thing I tried is to get the MonoGame source and build it, then link to the Project output. I was able to build MonoGame/MonoGame.Framework.Android.sln but when I try to link to it via local Project Reference it doesn’t allow me to.