Running my application outside of the development environment - help?


I’m currently developing my first MonoGame project. It’s been a learning process for me, as this is not only the first time I’ve worked with MonoGame, but also the first time I’ve done any game programming of any kind. My project has been underway for a few months now, and I think I’m making good progress on the actual programming side of things! I have a prototype for my game running fine within Visual Studio on Windows 10.

The other day I was thinking about potentially taking a version of the game so that some other people could test it on their own computers. I know Visual Studio has its own publish function that creates an installer; I tried that, and had issues which I think I’ll leave to explore for another time. In the meantime, I just want to get my game running from the executable that Visual Studio produces in its “release” folder for the project.

I have been told that, after building my project in release mode, I should be able to double click the executable in that folder, and that it should run (so long as I don’t remove any of the other files surrounding it). However, attempting to run the executable does… nothing. The mouse icon displays the loading animation for a few seconds, and then nothing happens whatsoever. I don’t even get a process showing up in my task manager.

I did some searching around the issue, and saw some people who had a similar-ish problem caused by avast antivirus; however, disabling (and in fact, uninstalling) avast temporarily didn’t fix the issue.

I am running Windows 10 and working with MonoGame in Visual Studio 2017. Again, the game runs fine in Visual Studio, but attempting to run the executable in any way outside of it appears to have no effect. Am I missing something?


Inside visual studio you are also running the generated .exe, so it should work and this is also an easy way to distribute your app - just share the output folder containing the executable. I do that all the time, it should work.

Maybe you are building the debug version by default and the release build is not properly working or hasn’t been updated in ages?
Try to see if the exe in the bin/…/ debug works and try to check your build properties for the release configuration

No, I’m definitely building the release version. I built a new release version specifically when I was attempting to do this.

I have also tried the bin/…/debug version, and that doesn’t work either. For both versions, attempting to run the .exe has seemingly no effect.

I have done this on multiple occasions. Still no joy.

Seem to have found a solution. Nevermind.

Is this on the same computer that you develop on? If you want to run on another computer it’s common to have to install an directx or opengl redistributable.

Could you describe the solution you found? It may help other devs having similar issues.