Runtime error Device.GetSupportedFeatureLevel in uwp app

Hello mono team and mono users. I would first like to say thank you for all your hard work on this awesome platform. For the last year i have been working on my own UI framework, which really is the base of what i have with my game (IE no game really yet). In any case i am getting a runtime error (Device.GetSupportedFeatureLevel error) when i try run my UWP app using the monogame nuget and my pre existing code (the code is platform independent as far as i can see and compiles right now as a win32 app). I have tried to find where the missing .dll reference is but the best i can tell is it is trying to reference a method in the sharpdx libraries that either isnt there, or the dll is not getting copied over because the monogame uwp template is failing to copy it? i also tried referencing sharpdx in my project to see if that fixes the issue, but to no affect.

when i first created this test solution i created it using the already installed monogame 3.5 template from the new solution menu in visual studio 2015, not from installing the nugets on a blank uwp application. I might go back and try recreating a blank uwp and installing monogame reference from the nuget manager?

I apologize if i am long winded, thank you for your help and ideas. Hopefully we can solve this for the next person.

Error message from output:
Exception thrown: ‘System.Exception’ in MonoGame.Framework.dll
An exception of type ‘System.Exception’ occurred in MonoGame.Framework.dll but was not handled in user code
Additional information: Method ‘Device.GetSupportedFeatureLevel()’ was not included in compilation, but was referenced in GraphicsDevice.PlatformGetHighestSupportedGraphicsProfile(GraphicsDevice). There may have been a missing assembly.