SharpDX missing for Universal app - Best way to get it?

My MonoGame library uses the latest public NuGet packages. I want to create a version for UWP and test in a UWP app. I created the UWP app, added the MonoGame Universal NuGet package but SharpDX is missing. What is the best way to add references to SharpDX? Which version should I download?

Are you using Dev branch or Release branch? 3.6~ or 3.5.1~?

I use the downloads from the download page, not the NuGet nor the Git so I don’t know if the Dev branch is available on NuGet or not

I’ve been using the release repository. They have a nuget server for the dev branch but I don’t want to use unreleased stuff for my release.

So… 3.5.1? :hushed:

Try posting the exact error message as well to help…


Hm…it’s just an unhandled exception (caught by the global handler) that says SharpDX.dll is missing. I created a new Universal App, added the MonoGame NuGet package, used the starter code (game class, game XAML, app.cs) from the MonoGame installer to get a “game that clears the screen” running.

I tried installing SharpDX and then referencing those libraries and it gets passed the “SharpDX dll missing” error and just crashes with no information.

I was hoping someone here actually created a universal app game and could say what they did.

I did try using the MonoGame template but

  1. It’s using an old version of MonoGame
  2. Visual Studio 2015 U3 refuses to actually create the project with some error about an application wizard not being available.

Which is why I’m trying to do it by hand :smile:

Take a look in here:

and have a browse here:

MonoGame UWP uses old nuget packages for SharpDX… you have to install whichever SharpDx package it is complainging about, and then downgrade it to 3.0.0

If you try to just use the latest, that’s when it starts throwing “SharpDx not found.”

Hope this helps. Cheers!

Thanks. I was still having odd issues when using a new UWP app project + nuget monogame. Modifying the UWP MonoGame template and creating a project that way fixed it for me for now.

I’ve run into a different though similar issue. I have two projects:

  1. UWP library that uses MonoGame Universal (referenced via program files)
  2. UWP App that uses MonoGame Universal (referenced via program files)

I’m running into these weird scenarios:

  1. UWP app references the UWP library directly as a project reference.

    SharpDX files and MonoGame are copied to app output and game runs

  2. UWP app references my NuGet package of the UWP library.

    SharpDX files are not copied to output, MonoGame is copied. Game will not run

Any idea why referencing the my NuGet package (which has a reference to the program files monogame.dll) causes the sharpdx files not to be copied? So strange and frustrating.