[SOLVED] Apps won't run on my laptops anymore [USER ERROR]

I have a strange problem with my Monogame executable. I was able to run it at first on both of my laptops (windows 10). Then it crashed, and now I am unable to start it again. How is it possible that it worked before and now it doesn’t? I don’t get any error message or anything. I just get an hourglass and then nothing. I’m considering switching to another engine because I think I tried everything and the project just won’t work…

Go right ahead. :coffee:


In case anyone in future is wondering why I said so:

Have you looked in the Event Viewer to see if there are any errors listed in there?

Can you debug it on that machine?

Are your video drives up to date?

UAC turned on or off?

I’d also consider it an antivirus problem. Check that your game is not being blocked by the antivirus.

I don’t think discovery is the issue here, it’s an issue of character.

I think @Teup might be better served by a point and click solution.

Thank you for your suggestions. I’ve been working on the issue most of the day today and worked out the initial crash was caused by a texture being very large. Cutting it into pieces appears to solve the issue (oddly, all pieces are still drawn, so I would expect it wouldn’t matter whether it is one large texture or several smaller ones).

I was surprised to see that I could not start an application again after it had crashed - never seen that kind of behaviour from Windows before. After the Windows update I was able to run it again, and after cutting the texture in 16 pieces I was able to run it without freezing. Problem solved for now, it seems!

If you cause a lock operation, it will happen, just open task manager and kill the app…