[Solved] Compiled Content does not end up in game directory


I recently started having the issue where the Content Manager doesn’t copy the files to the game directory. They build without error and they are in the content folder but never get copied to the game directory.

Any ideas?

#----------------------------- Global Properties ----------------------------#


Have you tried, I dunno, manually adding them? are you talking about not using copy if newer??

Manually moving the built copies to the game directory is what I am currently doing and as you might imagine is quite annoying when you are writing a shader file and every single time you make a change you have to manually build the file and then copy it to another folder when this is normally done automatically.

Copy if newer would work if the files were inside VS2017 but they are not.

I figured it out. At some point the Content file had it’s build action set to none instead of MonoGameContentReference. This fixed the issue.

Pretty much what I was talking about, just been away from VS for too long…