[Solved]Content.Load<Model> ContentLoadException


I’m trying to learn to use MonoGame for a project, but for some reason when I’m trying to load a model I get this exception.

Message=Could not find ContentTypeReader Type. Please ensure the name of the Assembly that contains the Type matches the assembly in the full type name: Microsoft.Xna.Framework.Content.ReflectiveReader1[[Microsoft.Xna.Framework.Content.Pipeline.Graphics.MaterialContent, MonoGame.Framework.Content.Pipeline, Version=, Culture=neutral, PublicKeyToken=null]] (Microsoft.Xna.Framework.Content.ReflectiveReader1[[Microsoft.Xna.Framework.Content.Pipeline.Graphics.MaterialContent, MonoGame.Framework.Content.Pipeline]])

I can load Texture2D just fine, it only happens with models.

I am using the latest development build (3.7) as I couldn’t create a project using 3.6.

Seems to be the same issue like I had. I think it was introduced after the last official release (MonoGame 3.6)…


Please, go to the references of the project, and then the properties of monogame reference(s) and verify the path and version. Then come back to tell the results :blush:

Did you find what’s causing it?

I have managed to fix it by uninstalling the SDK and then installing the latest stable version (3.6), removing the reference and then adding it again manually.

I have tried 4 different 3.7 builds and I have had the same problem with all of them.

Yes, that is also what I tried. Same result for me. Latest stable version (3.6) works but installation of newer builds does not work.

I was just suspecting something like that:

If your model is an .FBX try to switch from “Open Asset Import Library” to “Fbx Importer” in your .mgcb file.

FYI. We’re working on a fix https://github.com/MonoGame/MonoGame/issues/6179.

1 Like