[SOLVED] Exception in SharpDX using Sandboxie

Hi! I have a small problem with my game…
I get this when I’m starting it in a virtualized environment using ‘Sandboxie’:

Microsoft.Xna.Framework.Graphics.NoSuitableGraphicsDeviceException: Failed to create graphics device! ---> SharpDX.SharpDXException: HRESULT: [0x8007007E], Module: [Unknown], ApiCode: [Unknown/Unknown], Message: The specified module could not be found.

   at SharpDX.Result.CheckError()
   at SharpDX.Direct3D11.Device.CreateDevice(Adapter adapter, DriverType driverType, DeviceCreationFlags flags, FeatureLevel[] featureLevels)
   at Microsoft.Xna.Framework.Graphics.GraphicsDevice.CreateDeviceResources()
   at Microsoft.Xna.Framework.Graphics.GraphicsDevice.PlatformInitialize()
   at Microsoft.Xna.Framework.Graphics.GraphicsDevice.Initialize()
   at Microsoft.Xna.Framework.Graphics.GraphicsDevice..ctor(GraphicsAdapter adapter, GraphicsProfile graphicsProfile, PresentationParameters presentationParameters)
   at Microsoft.Xna.Framework.GraphicsDeviceManager.Initialize()
   at Microsoft.Xna.Framework.GraphicsDeviceManager.CreateDevice()

It only happens on my smurf-account (steam) I use to test MP.
I really don’t know Sandboxie well. Just used it to access a second Steam account on my dev-computer to test MP…

Everything works fine locally on my main account. The smurf account is embedded in a sandbox using ‘Sandboxie’ so there may be some resizing involved when it’s displaying.
I also tried searching this board and I found this:

So I tried using the app.manifest from github Jjagg provided somewhere else on this board… https://github.com/Jjagg/MonoGame/blob/develop/ProjectTemplates/VisualStudio2010/Windows/app.manifest

But nothing changed…
Still the same behaviour (added it in my project; set to copy-if-newer; Added it in the projects properties via dropdown). Still works locally, but not on sandbox.
The odd thing is that it only happens with Sandboxie… I’ve tried a full VM -> works; no problem (but slow :blush:)
like a charm… That issue sadly is so much beyond me. I fear I cannot help even getting the simplest debugging infos.

Any ideas. Thx in advance.

Additional Info:
I’m using MG 3.6.0.1011 (via installer from TeamCity)

What is ‘Sandboxie’? am I to guess it is Linux related? if so, this post should be marked under Linux and not Windows…

EDIT never mind managed to find it, Should you not be asking this support on their forums instead? as it is unrelated to MonoGame…

That’s the problem. I don’t know if it’s unrelated since virtually every other game works from out there.
So it may be MG related since it stopped working since I switched to 3.6.
I’ve tried to investigate on their board since it seemed logical that such an error would hit many games so it should pop up somewhere over there, but I couldn’t find anything.

Umm… did you read it at all?

Sorry. Not sure what you’re trying to tell me.
If it’s a dumb mistake I made then that’s great; I can move on.

The stacktrace comes out of a release-build since I only push those to Steam and the virtualization runs steam…

Hopefully someone else can shed light on the issue…

Meanwhile I’m preparing some more tests. Can’t hurt. Thx anyways.

1 Like

OK. All-clear.
This is probably not a MG bug.
I started a small project and ran it in and out of Sandboxie and both MG versions I tested (3.5.1 and 3.6.0.1060) worked fine.
Now I have to determine what I do differently in my game than in this small example-project.

2 Likes