[SOLVED] Importer 'TextureImporter' had unexpected failure (Tried re-install C++ Redistributable but not working)

(Update: I’ve reinstalled them all, not working. I’ve tried removing all x86 version like I read from other another post, still no luck.)

Hi guys,

Newbie here. I noticed there were solutions stating that have visual C++ Redistributable 2012/2013 installed could solve the problem whereas I pretty much installed them all but VS still complains. Any ideas? Thx~~


(I’m using latest version of VS 2019 and Monogame.)

(github link I’ve read: https://github.com/MonoGame/MonoGame/issues/3556)

Have you tried another image?


Hi! @Jeff_Stone, Welcome to the Forums!

Happy Coding!

1 Like

@MrValentine thx :grinning:!

I just tried, same error:

Also, I notice there’s a “best fix” to it:

More info in #4445:

Haven’t tried it though… Not very familiar to some of the terminologies here, I guess PR stands for pull request?

I’m still looking for a easier way. The error happened when I was going through “Getting Started” at https://docs.monogame.net/articles/getting_started/4_adding_content.html

Try repairing Visual Studio for starters while someone comes by…

1 Like

Have you tried running Dependency Walker on your own to see if you’re missing something like they did in that post you linked to?
Are you running MonoGame 3.7.1 or 3.8?

1 Like

@MrValentine @Synammon
Thx guys, problem solved.

Your advices, I just did them both.

First download a FreeImage.dll and put it into SysWOW64 (not sure if this is the right place for it though, 64 bit Win10).

Restart computer then repair VS. Now it works!

I’m using Monogame:

Love this community, thx again!

1 Like

Could you explain, please:
From where do you download a FreeImage.dll - and where do you put it?
And afterwards you do a Repair on Visual Studio?

Thanks a lot…

Just search the forum for it…

Just read the thread, the link at the end is what you want, I guess.

Usually you would place it in the same folder as your executable…

Good luck!

@morten I don’t remember which website, just google it and download.

  • Put it into “C:\Windows\SysWOW64” (Honestly, Idk if this is the correct place or if this step matters)

  • Restart computer, open up VS installer then Repair.

1 Like