[SOLVED]Loading XML Content from IntermediateSerializer failing

I have some custom content that defines sprite sheets that I serialize using IntermediateSerializer. It is being compiled to XNB file. Now when I try and bring it back in using the ContentManager I’m getting an exception that a ContentTypeReader could not be found, see below. This is with is with MonoGame 3.8. It previously worked in MonoGame 3.7.1. I’m probably missing something obvious but any thoughts?


  Message=Could not find ContentTypeReader Type. Please ensure the name of the Assembly that contains the Type matches the assembly in the full type name: Microsoft.Xna.Framework.Content.ReflectiveReader`1[[Psilibrary.SpriteClasses.SpriteAtlas, ShadowLib, Version=, Culture=neutral, PublicKeyToken=null]] (Microsoft.Xna.Framework.Content.ReflectiveReader`1[[Psilibrary.SpriteClasses.SpriteAtlas, ShadowLib]])
   at Microsoft.Xna.Framework.Content.ContentTypeReaderManager.LoadAssetReaders(ContentReader reader)
   at Microsoft.Xna.Framework.Content.ContentReader.InitializeTypeReaders()
   at Microsoft.Xna.Framework.Content.ContentReader.ReadAsset[T]()
   at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   at ShadowEditor.Editor.Update(GameTime gameTime) in C:\Users\Cyn\Documents\GitHub\MonoGame.ShadowMonsters\ShadowEditor\Editor.cs:line 699
   at Microsoft.Xna.Framework.Game.DoUpdate(GameTime gameTime)
   at Microsoft.Xna.Framework.Game.Tick()
   at Microsoft.Xna.Framework.SdlGamePlatform.RunLoop()
   at Microsoft.Xna.Framework.Game.Run(GameRunBehavior runBehavior)
   at ShadowEditor.Program.Main() in C:\Users\Cyn\Documents\GitHub\MonoGame.ShadowMonsters\ShadowEditor\Program.cs:line 17

IntermediateSerialiser does not work for me anyway

to serialize instead use xmlserilazer I have already posted below:
Help Load & RW Xml if that can help you serialize;

second possibility if you want to use the Content in this post

What is troublesome is that it is working fine in another project, just not this one. As far as I can tell there is nothing different between the two projects. They share a copy of the same library with a few tweaks for the difference between the games. I can’t serialize without the IntermediateSerializer because I have Dictionary fields in my classes and that is not supported. At worst I could manually parse the XML in a content reader.

IntermediateSerialiser it no longer works with version 3.8

you can serialize with xml serializer and save in a List.

I created a new project, copied over the content and code and it is working fine now. Just finished up testing it.