[SOLVED] Monogame 3.6 not building PNGs

Hello, I am running MonoGame 3.6, with Visual Studio Community 2017, and when i try to build some pngs for a C# game I get this error

I’m on a 64bit windows 7 professional. The freeimage.dll is in the same folder as pipeline.exe, and i dont know what else to do.

You need VC++ 2012 redist on your machine. You can download it from the Microsoft website: https://www.microsoft.com/en-us/download/details.aspx?id=30679

The FreeImage assembly depends on it and if one of the dependencies is missing when loading a dll you get this confusing exception.

Thank you im installing it right now, anything else i need to do?

Wait, still got the same error when trying to build

I had this same error with a library that a friend of mine wrote in C++ on Linux. The way I figured out what the C# error was ACTUALLY saying was I used Dependency Walker.

Basically, you download that program, open it, and open the FreeImage DLL with that program. It’ll scan it and look for missing dependencies. If it finds some, it’ll tell you. It’ll list all DLL files that the library is looking for but couldn’t find. Just google the file names and in most cases you should find downloads for the relevant libraries.

Good luck!

1 Like

I got this window when i opened it

From what I can see you’re missing VCOMP120.DLL (see the yellow question mark next to it?)

I’m not a Windows user myself (well, not entirely true. I just switched to linux a few days ago, won’t ever be going back) but from a little bit of googling all I could really find is “Try rebooting your system to clear out any software conflicts caused by installing new programs/updates.” Typical Windows troubleshooting guides.

But, in case you haven’t rebooted after installing VC++ 2012 Redistributable, I’d give your computer a nice reboot and then try using the pipeline again to build the PNGs. If there’s still an error then…as I said I’m not really a Windows user anymore so I’m not REALLY the best person to help out with this stuff :stuck_out_tongue:

Edit: IESHIMS.DLL’s another one that’s missing. Didn’t catch that one at first. No idea what the hell that is or what it does.

I get this error when i try to move the new vcomp120.dll into freeimage.dll. (Im using 7-zip)

This really seems like c# is not meant to be with me lol

You don’t need to put the vcomp120.dll INSIDE FreeImage.dll. That’s not how DLLs work.

Also this isn’t the fault of C# or monogame itself. This is the fault of Windows - one of the main reasons I switched from it to Linux. Windows’ package/library management is absolutely horrible.

so i just need it in the tools folder?
Sorry of my ignorance, im brand new to this


1 Like

Glad to hear it’s working now :smiley:

Have fun with MonoGame!