[SOLVED] MonoGame nuget packages not loading.

I’ve been having this problem for a while now. I create a new MonoGame project in visual studio and when it loads up there’s a little warning sign on the MonoGame NuGet packages:

Also, VS isn’t able to resolve the Xna namespace.

Any Help would be very much appreciated.

I have had this happen before, try the following:

  • On the solution pane expand the Dependencies / Packages
  • Now write down the names of your MG packages.
  • Once you have saved the names manually remove those MG packages.
  • Go to VS menu and do a File / Save All
  • Close your Solution
  • Open your Solution
  • Now open VS menus item Tools / NuGet Package Manager / Manage NuGet Packages For solution
  • Just add back the MG packages that you removed to your solution
  • Give it a few minutes after you add them back and everything should be resolved and fixed

This seems to work every time I have the issue, I am not sure what the cause is for it happens only sometimes(recently I not run into it for a very long time). My bet it is a VS issue and nothing to do with MG.

Good luck.

1 Like

Thank you! It worked!

1 Like

Awesome, I am glad it helped out and you got it working :slight_smile: