[SOLVED] MonoGame Pipeline Tool not doing anything when clicking Build, Rebuild or Clean in the GUI menu

I found this thread here and I have the same symptoms on my machine:

So if I open the MGCB GUI and click on Build nothing happens at all. As mentioned in the other thread I changed the language to something else and that maybe had an effect on that. I then got a popup when clicking on it asking me to “Choose Just-In-Time Debugger”. I can click on Cancel and the content gets build without issues after that or I can click on OK and when using Visual Studio as Just-In-Time Debugger I have the option there to “continue execution” and then also everything gets build.

But at the moment it is back to doing nothing at all.

Anybody knows how to fix this?

Is it asking to debug when you click build? Which version of MonoGame are you using?

I’m using version

Yes, but only now and then it asks me to choose a debugger. At the moment it does nothing at all for example. I haven’t figured out why.

I tried to change the language settings because it was mentioned in this thread:

And after that I got the question for choosing the debugger. Then I wanted to record a gif showing the choose the debugger option but at that point it was just back at doing nothing and also changing the language didn’t help (also not sure if this helped the first time, maybe it was just a coincidence).

I could try to build the MGCB tool from source. I mean content gets build if I build the solution so content building does work I guess but the tool is not. I would then need advice how to get it build from source. I can checkout the git repo and I tried to checkout the tagged commit which corresponds to my installed version because I am not sure if the latest version is functional? But when I checkout this version I think the git third party projects are not checked out so that everything works?

Maybe its the same issue as described in this post of the same thread mentioned above:

So if I get a bit help with getting the MGCB tool up and running from source I could debug it and see if it is the same.

Building from source is simple. Clone the repository then checkout the develop branch. Then run Protobuild.exe which will generate the solutions, and you can build the pipeline tool for your project type. This post explains more.

Thanks I managed to compile the Pipeline Tool. This is version v3.7.1 (I checked out the commit with v3.7.1 in the repo and ran Protobuild.exe after that and openend the Windows.sln set the Pipeline project as startup project and tried to build some content).

So there this is a bug in v3.7.1 I guess. I will try to repeat this with the latest commit in the develop branch to see if this was already fixed somewhere.

If not the question is how to proceed now. Maybe it works if I use a more recent develop version of the Pipeline Tool. It should work if the Pipeline Tool itself is compatible with the MGCB command line tool for content building I think.

I recorded a gif, just click on the image and it should play the gif:

Edit: No luck so far with the latest develop version…

I just changed

            Encoding encoding;
            try {
                encoding = Encoding.GetEncoding(CultureInfo.CurrentCulture.TextInfo.OEMCodePage);
            } catch (NotSupportedException) {
                encoding = Encoding.UTF8;


            Encoding encoding = Encoding.UTF8;

in the source of version v3.7.1 and everything works. So that is the solution for me for now.

I followed exactly the described steps of the documentation to clone the repo described here under “Getting the source code”:

After that I checked out version v.3.7.1 with I think this command (just make sure to checkout the tagged commit):

git checkout v3.7.1

Only after that step I ran Protobuild to make the sln files and started the windows.sln made the changes in the source and compiled the Pipeline tool. After that I went to some other MonoGame sln file which has content and right clicked the content.mgcb file inside Visual Studio and chose “open with…” see screenshot. There I chose the bugfixed pipeline.exe. So now I can open the mgcb files inside Visual Studio and they get openend in the bugfixed version.

Just wanted to describe the whole process if anybody gets the same issue at some point and needs a solution.

Yes, that’s an old bug.

I looked into it and found out that this bug has already been fixed on the dev branch:

Just linked this here for future visitors.

1 Like

BTW, had this issue today.

I had this same issue but I actually fixed it. If you installed visual studio and didn’t enable JIT ( Just-In-Time debugging), you may get this error + I got the exact issue. I could compile my content files 100% fine but it would cause the JIT to have issues.

Since dotnet core or future of dotnet which isnt .Net Framework anymore, you will still get this error. If you are using Visual studio Code OR Visual Studio without Jit, you may get this error.

I fixed it doing this: Debug using the Just-In-Time Debugger - Visual Studio (Windows) | Microsoft Docs

Basiclly opened up my reggit and removed the entries and the error went away.