[SOLVED] MonoGame windows project can only build x86

I want to be able to build x64 or Any CPU, but it will not let me. I am stuck building into x86.

My MonoGame version is I cannot update to the latest as I had issues with the Content pipeline erroring when loading assets.

Initially I thought Visual Studio Community 2017 was bugged because when I selected x64 in the taskbar dropdown next to Debug and Project Name, then clicked Run, it would not build the latest code changes or message me if there was an error.

This is strange because all other projects i’ve created with VS work fine, including Monogame UWP project. I’ve always used the taskbar dropdowns to build and never had this issue before.

I delved into it further and found the following:

R-click project > Properties:
Platform: Active(x86) is the ONLY option in the list.

Platform target contains x86, x64, Any CPU.

Even if I change the Platform target to x64 or Any CPU and manually change the Output path, it will run whatever is in the output folder, but will not build there.

Any ideas?

Can you change it in the platform in Build > Configuration manager ? Are you allowed to change it there ?

1 Like

Hi, The active solution and all projects can build at x86, x64 and ANY CPU.

However my Windows project as part of the solution only has x86 in the list, but on closer inspection I noticed a New… option in my Windows project list.

I have added x64 and Any CPU, then selected each active solution platform and set up that Windows project to build to the correct solution platform.

You pointed me in the right direction and its working as expected now thanks so much!

:wink: (20 characters… )