[SOLVED] OpenAL drivers could not be found

Hi there,

if I´m creating a new “Monogame Mac Application (Xamarin.Mac)” in Xamarin Studio (on a Mac) and try to load a soundeffect via
I get the error “Microsoft.Xna.Framework.Audio.NoAudioHardwareException” and “OpenAL drivers could not be found”.
I tried adding openTK but then it won´t even come to that line (I guess because OpenAL is already in the monogame-framework and there are two different version around).
The libopenal.1 is included as a native link in the project.
I found another thread that had the same error in a desktopGL-Project but couldn´t really figure out how they solved it.
If I create a “Monogame Mac Application (MonoMac)” it works but then I can´t publish it to the store because people need to install MonoMac in addition to my app (or am I wrong?).
I´m using the newest Monogame and if I uncomment all soundcode the whole game works like a charm.
Am I´m doing anything wrong?

Thank you in advance,


I tried it with the newest Version 3.6 and when it tried to load the content-file the cpu-load got up and the app freezed (even before it opened the window of the app. I then played around with the content-options and if you set the quality of the mp3-import to high it freezes. If you set it to medium or low it works. Don´t know why but I guess that´s the way to go.
EDIT: The content is loaded but can´t be played. It just does nothing! I´m trying to use the Mac-OS soundlibs now and report if I was succesful.
EDIT 2:If you set the “Platform Target” to X64 under Project Options/Compiler page the loading works even with bigger files. The music is played just nice.