[SOLVED] Pipeline Tool Crashes on macOS.

I’m unsure whether I’ve posted this to the correct category or not, however, I’ve set up my environment for MonoGame on macOS and though everything works as intended the Pipeline Tool seems to crash on launch. If I run the .app file from my Applications Folder it closes instantly, if I run it from the Terminal using: open -a Pipeline the error that I receive is: LSOpenURLsWithRole() failed for the application /Applications/Pipeline.app with error -10810..

I have of course installed Mono, and as aforementioned everything works as intended but the Pipeline Tool. I’m confused as to why this is occurring.

  • macOS Catalina 10.15.4
  • Mono JIT Compiler (also tried with

Any help with be very much appreciated.

That sounds like a Mac quarantine error

You can see if this is your problem by listing the xattrs. cd /path/to/your/ApplicationName.app xattr -l Contents/MacOS/*

If you see “com.apple.quarantine” then that’s your problem.

I think you can fix it with something like

xattr -dr com.apple.quarantine <application>

The other thing to worry about is Catalina dropped support for 32 bit apps. Check that the tool is 64 bit

1 Like

That seemed to have worked. Thank you so much, would have never of thought that’d be the issue!

I have the exact same problem. Same macOS version, same Mono version, and same error -10810.
But when I tried checking the xattrs, nothing shows up so I’m guessing its not the same case.
I also have checked that the Pipeline Tool is actually 64-bit, so I legit am so confused right now as to what the problem is.

The only thing I can suggest is that you make sure you’ve downloaded the Pipeline Installer from here: MonoGame 3.7.1 Release instead of the Development Build, a mistake I initially made. If that doesn’t work I don’t know to suggest. Hope this helps!

1 Like

OMG THANK YOU!!! IT FREAKING WORKS what the hell lmao!
I swear I spent the entire day looking for a fix to this and nothing worked until I tried installing the one from the download link you gave.
This is actually the first time I asked anything in any sort of forum and I am actually very surprised to see how fast someone replied to my otherwise irrelevant question.
You sir, get all of my thanks!!!

Not a problem. I’m happy it helped!

No question is irrelevant and someone will always be happy to help! Have fun making games dude and stay safe!

Fresh install on Mojave here. Didn’t work at first. I had it working on another (Mojave) Mac, so I knew it had to work.

Using the standalone Pipeline installer from the download link, I got this error:

The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/Library/Frameworks/Mono.framework/Versions/5.8.0/lib/mono/4.5/mscorlib.dll’ directory.

Mono 6.8.0 was the only version that was installed, I double-checked. (Maybe there was a dangling reference to an earlier 5.8.0 install?)

Anyway, installing MonoGame.pkg (full installer) made it work. I’m a happy camper.

Thanks ! That comment was also a life saver for me (ok not life, but a solid 2 hours of internet searches :D)