[SOLVED] The Newest version of VS2019 and Pipeline Tool


Today, I updated VS2019 to newest version. After that I created new monogame project and I wanted to add some textures, but pipeline tool isn’t working. It is showing me .mgcb file like a text file and If I right click on it and click open with pipeline tool it’s showing me error: The operation could be not be completed. Parameter isn’t correct. What am I supposed to do now? For any help thanks.

The easiest way is to just right click on your project’s Content.mgcb, click on Open containing folder and start it from there.
Alternatively, you can start the Pipeline.exe separately (it’s in C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools\Pipeline.exe but you can also just search for it - Press the Windows key and type pip, that should be enough) and navigate to the .mgcb you want to use from there, or just look for it in File -> Open Recent.

I tried it but i think that pipeline just broke. I’m double clicking it but nothing happens. I think i need to reinstall pipeline or something

Ok, i just reinstalled monogame and it works, but not in vs2019 so thanks