[SOLVED] Unable to load MonoGame.Extended solutions in Xamarin Studio

Just a heads up, maybe this will get fixed later, but on the develop branch I get “Load failed: Unknown solution item type” on some projects when opening MonoGame.Extended in Xamarin Studio (Community 6.2 on macOS).

That’s interesting. I created those projects recently and they work in Visual Studio as expected.

Obviously, there’s something different about the existing project files that I’ve missed. It would be interesting to compare the differences between the ones that load and the ones that don’t.

How is Xamarin Studio these days anyway? Last time I used it, it was quite buggy, although that was in the early days so I assume it’s got better. I might download Xamarin Studio for Windows and see if the same error shows up. At least that way it can be prevented in the future.

Thanks for the heads up.

FWIW they load OK in Preview 4 of Visual Studio for Mac (essentially Xamarin Studio 7.0), but there’s no MonoGame addin for that yet.


Didn’t try the XS 6.3 on the alpha updates channel. Maybe that fixes it.

XS got better in the 6.x series, and finally has a dark skin :slight_smile: It’s still a bit sluggish and crashy but basically fine. TBH I’m still looking forward to Jetbrains Rider, but that might just be because I’m used to their tools from %DAYJOB%.

I don’t think there’s a good reason why they don’t load for you. It’s probably just a minor change to the project file to fix it. If we open up a project file that loads and one that doesn’t there’s a couple of noticeable differences but not many.

The first difference I noticed was the ToolsVersion. Maybe try changing that to 14 and see what happens?

Could you have a play with it and see if you can get them to work then report back here with what changes you had to make. I suspect it won’t be much.

I’m generally a big fan of Jetbrains products. I don’t think I could live without Resharper. I tried Rider in the EAP for a bit and it looks awesome but I found it a little too immature. I mean, that’s to be expected I guess but I’m not currently using it.


That was literally all I had to do :rolling_eyes:

All projects now build in XS.

I changed the ToolsVersion in all of the project files to 14.0.

As far as I can tell it makes no real difference to Visual Studio users anyway.

How the ToolsVersion Attribute Works

Starting in Visual Studio 2013, the MSBuild Toolset version is the same as the Visual Studio version number. MSBuild defaults to this Toolset within Visual Studio and on the command line, regardless of the toolset version specified in project file.

Just gotta remember to do this for any new projects somehow :worried: