[Standalone / Non-VS version] MGCB Editor doesn't open.

Hey folks :wave:, I’m in college and my teacher is lecturing with this tool “MonoGame”, but I personally don’t use VS but instead I use Rider. And I am having no success in running the MGCB Editor in a “standalone” version.

I followed the instructions, through the first step and then the last step which was to install the editor.

My dotnet info:

Sokoban % dotnet --info      
.NET SDK (reflecting any global.json):
 Version:   6.0.108
 Commit:    4e3a463d2b

Runtime Environment:
 OS Name:     Mac OS X
 OS Version:  13.2
 OS Platform: Darwin
 RID:         osx-arm64
 Base Path:   /usr/local/share/dotnet/sdk/6.0.108/

global.json file:
  Not found

  Version:      6.0.14
  Architecture: arm64
  Commit:       2a90daa2cc

.NET SDKs installed:
  6.0.108 [/usr/local/share/dotnet/sdk]

.NET runtimes installed:
  Microsoft.AspNetCore.App 6.0.8 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App]
  Microsoft.NETCore.App 6.0.8 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]
  Microsoft.NETCore.App 6.0.14 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App]

Download .NET:

Learn about .NET Runtimes and SDKs:

Project dotnet tool list:

Sokoban % dotnet tool list   
Package Id              Version        Commands         Manifest                                                         
dotnet-mgcb         mgcb             /Users/0rangefox/Projects/Rider/Sokoban/.config/dotnet-tools.json
dotnet-mgcb-editor      mgcb-editor      /Users/0rangefox/Projects/Rider/Sokoban/.config/dotnet-tools.json

If I run the command “dotnet mgcb-editor” it gives the following error:

Sokoban % dotnet mgcb-editor
Could not execute because the specified command or file was not found.
Possible reasons for this include:
  * You misspelled a built-in dotnet command.
  * You intended to execute a .NET program, but dotnet-mgcb-editor-mac does not exist.
  * You intended to run a global tool, but a dotnet-prefixed executable with this name could not be found on the PATH.

But when I do the following command “dotnet tool install dotnet-mgcb-editor-mac”, it stops giving more errors, but it doesn’t open the program either. Even in the folder the Mac recognizes which program to use, but it happens exactly the same when I run it through the command which is, it opens and closes instantly, in the dock it doesn’t even show the icon but does a spacing and goes back to the original.

I forgot to mention, but I downloaded the dotnet SDK via brew on the following tap and it is version, “dotnet-sdk6-0-100”.