Stuck on splash screen on Android


I’ve installed VS2015 with Xamarin and MonoGame 3.5 for VS2015.
I’ve used the built-in templates to create an Android project (the one that just makes the background light blue).
This compiles ok and runs on the virtual device. It displays the MonoGame splash screen, but goes no further. It doesn’t display the blue background.
The debugger shows that only the game’s constructor is called. The Update and Draw methods are not called. The debugger does not indicate the application has crashed. There are no exceptions. It just hangs on the virtual device.
I’ve tried using various AVDs (Android 6.0, 4.2.2, 5.1) and they all do the same.
If I create a project using the Windows template then this works - I see the blue background.
I’ve created CocosSharp projects which use Mono and these work ok.

As I’d downloaded the latest of everything and done all updates I would have thought this would work.

Any ideas anyone?

If I run the APK on a real device (Nexus 7) the app works and shows the blue background. So why does the AVD fail?