System.IO.FileNotFoundException: Could not load file or assembly 'PresentationFramework

I came back to running monogame after a year ish away and tried to make a new project. Checked the documentation because I couldn’t remember the details, and it told me to install the extension. Cool, I install the project templates extension. But, I go to open my content, and it won’t open, with the error message below. One post said to install tools, that they went away from a separate standalone app. Didn’t work. Another said uninstall the tools, which I did, and then follow the migration guide, which wasn’t helpful because the link 404’d. What do I do?

System.IO.FileNotFoundException: Could not load file or assembly ‘PresentationFramework, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35’. The system cannot find the file specified.
File name: ‘PresentationFramework, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35’
at MonoGame.Tools.Pipeline.Styles.<>c.b__0_0(MenuBarHandler h)
at Eto.Style.<>c__DisplayClass13_01.<Add>b__0(THandler w) at Eto.DefaultStyleProvider.<>c__DisplayClass9_01.b__0(Object widget)
at Eto.DefaultStyleProvider.ApplyStyles(Object widget, String style)
at Eto.DefaultStyleProvider.Eto.IStyleProvider.ApplyStyle(Object widget, String style)
at Eto.Widget.OnStyleChanged(EventArgs e)
at Eto.Widget.set_Style(String value)
at MonoGame.Tools.Pipeline.MainWindow.PipelineMenuBar…ctor() in D:\a\MonoGame\MonoGame\Tools\MonoGame.Content.Builder.Editor\MainWindow.eto.cs:line 24
at MonoGame.Tools.Pipeline.MainWindow.InitalizeMenu() in D:\a\MonoGame\MonoGame\Tools\MonoGame.Content.Builder.Editor\MainWindow.eto.cs:line 287
at MonoGame.Tools.Pipeline.MainWindow.InitializeComponent() in D:\a\MonoGame\MonoGame\Tools\MonoGame.Content.Builder.Editor\MainWindow.eto.cs:line 60
at MonoGame.Tools.Pipeline.MainWindow…ctor() in D:\a\MonoGame\MonoGame\Tools\MonoGame.Content.Builder.Editor\MainWindow.cs:line 46
at MonoGame.Tools.Pipeline.Program.Main(String args) in D:\a\MonoGame\MonoGame\Tools\MonoGame.Content.Builder.Editor\Program.cs:line 50

What is your development environment?
If Visual Studio, then you need to be on Visual Studio 2022.

Also, there are lots of posts on here looking for help around the time the change was made; searching those might help.

Visual Studio 2022.
Yeah, I searched those, as I mentioned in the description.

Found what worked for me. I went to try and install more Visual Studio components, but the Visual Studio Installer wouldn’t work. Turns out, I had to get the latest Visual Studio Installer for 2022, because there was a compatibility issue with older versions of the installer. Then I modified my installation and added anything that seemed like it might be relevant, like windows cross platform development, etc. Then I had to do a dotnet tool restore, then I could get it to work via terminal.