The audio is not working

I recently downloaded a game (superfighters deluxe) that uses the xnb file format for sound. When I start the game, no sound plays; only the music which is in a mp3 format plays. I made sure there was no problem with .NET framework (I repaired it many times using the tool from microsoft) and reinstalled XNA framework. I made sure the problem wasn’t within the game as I tried another game (Terraria, also as you know uses .xnb files),which also produced no sound, and tried the game on another PC and it worked. Please help, and I am sorry for any disturbance.

Try upgrading DirectX and / or installing OpenAL. When you open your own project, be it OpenGL or DirectX, do you hear your own sounds?

I believe there is no problem with directX (many other games use it and it’s fine) and it’s the latest version. I installed openAl and it didn’t work :C.
I also have a question, can equalizers (I have waves maxxaudio pro as I have a dell laptop) be a problem ?

Yes, it is even possible. Try uninstalling that program, if it’s not good, reinstall the basic sound driver.

The other interesting question is, what happens if you start your own monogame project in Visual Studio and convert random audio files to xnb format, will they work on your machine?

Honestly, I haven’t ever programmed or used visual studio personally. But I believe no, the sound won’t be working (Two different games from two different companies using the same audio format .xnb didn’t have sound). Right now, I am trying to uninstall the sound equalizer.

If the issue is not resolved, try the following. I made a very simple game that plays the monogame sound. Just download from the link, unpack, there will be two projects, one OpenGL and another DirectX. When you open the exe file, you should hear the sound immediately, first from the left and second from the right speaker. This is made with the latest MonoGame SDK.

MonoGame Sound Test

Thank you so much for your attention. THE SOUND WORKED!! I was so happy to hear the sound. I believe the problem therefore is with the games and I shall see what can I do. Again, I really appreciate you help. :hugs::hugs:

Well, I’m still clueless, and have no idea what to do :slight_smile:

Try updating DirectX with this:

I think the problem may still be on your machine. I searched for the two games you mentioned and both were made with the traditional Microsoft XNA Framework. You should know about the old XNA that it could only be run in DrirectX mode under Windows, and once I had a case on an older machine that the game worked but there was no sound. At that time, the solution was to update the DirectX components.

I then read about the games and writes about superfighters deluxe as a machine requirement:

I think the problem may be that the old XNA Game Studio requires different system components or directX components than the newer version of MonoGame. This allows even xnb files to be encoded differently in the old XNA and the new MonoGame.

Trying to install DirectX 9.0, I wasn’t able to. It says that there is a newer version of DirectX. I checked the link of mythological interactive games, and all the software components they need are already installed -I even repaired Xna and reinstalled C++ 2010-. I couldn’t identify the problem, of course it’s within my machine :pensive:, but where?
I also have several questions:
1.If the file is accessed does that mean that is read ?
2.Can the problem be within steam?
3.What might prevent an xnb file from being executed?
4.I tried to uninstall the sound equalizer, but I couldn’t, so can it make such a problem?
5.If possible, could you send me a game that uses .xnb files?

And Good night :smiley:

I sent you a private message.

Sir, the sound didn’t work :cry:, but I’ve found some new interesting information; when I open terraria, the app doesn’t appear in the volume mixer. What can that mean ??